D-LINK DAP 2610 not booting - please help

Hi,

I tried to upgrade my DLINK DAP 2610 to the latest OpenWrt Snapshot (downloaded here: http://downloads.openwrt.org/snapshots/targets/ipq40xx/generic/openwrt-ipq40xx-generic-dlink_dap-2610-squashfs-factory.bin). After downloading the file, I did proceed with the upgrade via the DLINK Web GUI wich caused the AP to reload as expected but did not start anymore since there. The LED stays solid red for a couple of minutes after powering up and starts flashing then very slowly. The AP also responds to ping on his default 192.168.0.50 address, but neither ssh, nor telnet or http/https is working.

While searching around I found another forum post (-> [Solved] DAP-2610 Bricked - Help Needed), wheras I start doing tcpdumps on the Interface connected to the PC in the hope that the rescue tftp server is doing something or other communication of the AP - but unfortunetaly nothing comes from the AP at all.

As mentioned as well in the the other topic, I got some soldering equipment and a serial-to-usb adapter and connected it to my PC (baud rate 115200), on the TX, RX and GND connections, as they recommended to not use the 3.3V at all.

Even with serial connected, I can‘t see something during the bootup with putty - it just stays dark and is also not responding to any commands send via serial.

Any idea what i could try out additionally to get the AP work again?

Thanks!

In serial mode, try to change RX for TX (worked for me).

@jarvis Is your device working again?

Thanks a lot for your answer @Klingon, just had time today to check the Forum again :slight_smile: ! Indeed - replacing RX/TX and I could get something on the Serial Line.

It seems that TX is still not working though - as pressing "q" does not have any impact at all.
But anyhow here the output from the Serial Line, where in the end it seems that the AP is starting the Emergency Webserver on IP 192.168.0.50. Connected to my notebook I can Ping the AP on the 192.168.0.50 but the WebServer is not responding. Was it the same in your case as well?

press 'q' to stop autoboot:  0 
SF: Detected W25Q128 with page size 64 KiB, total 16 MiB
## Booting kernel from FIT Image at 840000a0 ...
   Using 'config@ap.dk01.1-c1' configuration
   Trying 'kernel@1' kernel subimage
     Description:  ARM OpenWrt Linux-5.4.71
     Type:         Kernel Image
     Compression:  lzma compressed
     Data Start:   0x84000184
     Data Size:    2870351 Bytes = 2.7 MiB
     Architecture: ARM
     OS:           Linux
     Load Address: 0x80208000
     Entry Point:  0x80208000
     Hash algo:    crc32
     Hash value:   f16b50a9
     Hash algo:    sha1
     Hash value:   86fa6e62b5e7344076a59db7df6272671733e14f
## Flattened Device Tree from FIT Image at 840000a0
   Using 'config@ap.dk01.1-c1' configuration
   Trying 'fdt@1' FDT blob subimage
     Description:  ARM OpenWrt dlink_dap-2610 device tree blob
     Type:         Flat Device Tree
     Compression:  uncompressed
     Data Start:   0x842bcf0c
     Data Size:    16875 Bytes = 16.5 KiB
     Architecture: ARM
     Hash algo:    crc32
     Hash value:   e7a06c3a
     Hash algo:    sha1
     Hash value:   28c7cf71c9e9385cc6b70b11dd98f3a945047797
   Booting using the fdt blob at 0x842bcf0c


 Check Image ... 
  
 Image has problem! ... 
Press 'q' to quit Emergency Web Server 0 s
eth0 PHY0 Down Speed :10 Half duplex
eth0 PHY1 Down Speed :10 Half duplex
eth0 PHY2 Down Speed :10 Half duplex
eth0 PHY3 Down Speed :10 Half duplex
eth0 PHY4 up Speed :1000 Full duplex

Emergency web server start......IP is 192.168.0.50 

Press 'q' to quit.

here also photo from the soldering I did, I've connected them like:

GREEN -> TX
YELLOW -> GND
ORANGE -> RX

In my case I pressed 'q' when it was asked during the boot time, as your log shows:

Then via http I was able to get into a recovery page and upload the stock D-Link firmware.
After that, my device worked again.

Did you connect the Serial also in the same way like I did in the photo above?
Have you connected 3.3V as well? And was in your case TX the spare one at the right side?

Sorry @jarvis I don't remember exactly how I connect the serial wires, but I remember the fact of changing RX for TX, and I'm not sure of connecting 3.3v. Try without 3.3v maybe it works.

Regarding to your log:

It seems http recovery should work.

Yeah, would think so too due to the log message ... but nothing's responding :confused:
Do you have any other ideas that I could try out? Something that I'm missing here?

Stupid idea, try it using another web browser (firefox, chrome, Edge.....).

tried it .. but not working neither :confused:

lol .. it wasn't the browser, it was the bloody antivirus :confounded:
at least I made it work now, could restore the AP with the OEM firmware!

@Klingon, could you find then also a working openwrt version or are you running the OEM Firmware as well?

Hi @jarvis

I'm using OpenWRT. I'm running the last snapshot version with no problems.

hmm alright .. will try it out again !

Did you tried?

I’ve loaded the latest openwrt snapshot now directly from the emergency server and see there, it’s working!!

Thanks a lot for your help @Klingon

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.