D-Link DAP-1620 B1 no 2.4 Ghz band

Hi, I have a D-Link DAP-1620 on which I installed Openwrt 23.05.5. It works as an access point only in the 5 GHz band. If I try to configure it in the 2.4 GHz band, no client can connect. With the proprietary firmware I was able to configure both bands and the single 2.4ghz band worked.
I don't understand the problem. I also see only one WiFi interface "radio0", is it right?

Thanks a lot

# iwinfo
phy0-ap0  ESSID: "underworld"
          Access Point: F0:B4:D2:23:44:05
          Mode: Master  Channel: 44 (5.220 GHz)  HT Mode: VHT80
          Center Channel 1: 42 2: unknown
          Tx-Power: 16 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -92 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/b/g/n
          Hardware: 14C3:7615 7615:14C3 [MediaTek MT7615E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '44'
        option band '5g'
        option cell_density '0'
        option country 'IT'
        option txpower '16'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'underworld'
        option encryption 'psk2'
        option key 'xxxxxxxx'

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde5:c23d:632d::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.253'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

Try running the following and let's see the results:

mv /etc/config/wireless /root/wireless.bak
wifi
cat /etc/config/wireless

I see this:

cat: can't open '/etc/config/wireless': No such file or directory

Try rebooting and then issuing the last two commands again.

# wifi
'radio0' is disabled
'radio0' is disabled

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

This indicates that the firmware is not seeing the 2.4G radio at all.

Have you tried flashing back to the vendor firmware to see if the 2.4G radio is working properly? I wonder if you might have a hardware issue.

Yes, with the D-Link firmware both the radios 2,4 and 5 Ghz worked. I could configure different SSID for the two bands.

My question was if you had flashed back to the vendor firmware (since you experienced this issue in OpenWrt) to verify that the hardware is still detected and working properly.

Which rev DAP-1620 you have? My question is because DAP-1620 B1 has different radio... From your screenshot is MT7615E, but in specs hw is MT7615DN - maybe that is the problem - wrong identificated...

No, I haven’t flashed back to the vendor firmware yet. I have the DAP-1620 B1 version

I'd recommend trying to flash back to the vendor firmware to make sure the hardware is functioning properly. When you do this, be sure to enable only the 2.4G radio, or give it a different SSID. This way you can guarantee that you connect to the 2.4G radio (and not the 5G one). This will be important because it is still possible that the vendor firmware will present a UI for configuring the device even if the hardware isn't working properly.

ok. How i do to flash back to the vendor firmware? I have tried with a D-Link Recovery GUI but the upload fails.

I think that the .bin vendor file is encrypted.
thanks

You could try firmware 2.01 (earliest available for that device on the downloads site). If that doesn't work, try the dlink-decrypt tool that is referenced in the dlink recovery page you linked.

1 Like

I also tried loading the firmware 2.01 but nothing and the dlink-decrypt tool does not work for the type of encryption probably. I found this article (for DAP 1620 and other) for decrypt using the "Rust" compiler but I do not understand how it works :pensive:

Decrypting D-Link Firmware Across Devices With A Rust-Based Library

Hi,
same problem with DAP-1620 B1, only one band is supported.
It worked perfectly with both bands right before openwrt flashing.

I will try to flash back original firmware, but I belie it's very likely that both bands will work again.

marco

Tested original firmware and it works with both bands as expected.

How did you flash back? I can't decrypt the original bin file.

I've found istructions here:

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=e4c7703d2a62b8914e4723adae3f67c68a57532c

Revert to OEM firmware:

not working. Is it possibile to share the decrypted.bin file? thanks

Can confirm that in original firmware it works correctly.
On OpenWrt 23.05.0 and 24.10 it doesn't work almost at all.

There's only one radio that shows up as radio0 (MediaTek MT7615E 802.11ac/b/g/n) even though apparently there should be two.
No way of making it work with both 2.4GHz and 5GHz at the same time, while it works with stock firmware.

The OS correctly installed drivers for MT7615E, and using lspci it looks like it's recognised correctly as "MEDIATEK Corp. MT7615E 802.11ac PCI Express Wireless Network Adapter (prog-if 80)"
No other devices are recognised on the PCIe bus (except a pci bridge)

Though that's not the radio device shown in the table of hardware for this model...