D-Link 860l B1 Unable to flash 22.03 factory image

I'm running 19.07 and want to flash the 22.03 factory image and reconfigure.
I tried the recovery mode of the router ( https://openwrt.org/toh/d-link/dir-860l_b1#recovery_mode), but all this does is reset the openwrt config and not boot into the d-link recovery mode.
Maybe i'm doing something wrong there?

However first time it reset my openwrt config i logged into the device with root and no password and restored backup. All fine again.
The second time, same, but after restoring the backup my old root password doesn't work any more. And ssh complains about ssh-rsa.

ssh -oHostKeyAlgorithms=+ssh-rsa root@
ssh: connect to host port 22: Connection timed out

So atm i'm able to use the router with the old config, but are unable to login. And also luci-material and luci-ssl seems to be gone.
Anyone an idea what to do to go into recovery mode?

tried failsafe https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset ?

1 Like

Not yet. I'll try that now.

I managed to go to recovery mode after all.
My mistake was, that i used the reset button while device was powered on.
Reading your link led me finally to https://openwrt.org/docs/guide-user/installation/recovery_methods/d-link_recovery_gui, which described in detail, that device needs to be powered off and reset button needs to be pressed while plugging in the power cable.

Now all is updated and reconfigured (except ipban) and working like a charm.
Loving the new openwrt even more!

1 Like

can you share boot file or full Damp for dlink 860l b1 plz
I have a broken sam device

Hi Mando2022,

there is no boot file needed for that. It is built into the router itself. It is a failsafe function.
In that mode i flashed the factory firmware from here https://firmware-selector.openwrt.org/?version=22.03.0&target=ramips%2Fmt7621&id=dlink_dir-860l-b1

Hope that helps.

hi cereS
Thank you for replying
Unfortunately, I changed the original boot to breedweb boot
and forgot to take a backup

I'm sorry, i do not have the original boot image from the device.
I cannot find a dumper tool, if you have a link i'm happy to dump it and post it here.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.