Custom hw Wwan IPv6 not working

Hi,
I am using a custom board which runs openwrt18.06. It basically works as a cellular hotspot. I am able to get wlan0 and wwan0 interface when using ipv4 but with ipv6, I am not able to see wwan0 and so no internet is available. I checked from the LTE and everything is working fine there.

Can someone please help me modify my config files to work properly for IPV6?

My current /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.56.1'
        option netmask '255.255.255.0'

config interface 'debug'
        option ifname 'usb0'
        option type 'none'
        option proto 'static'
        option ipaddr '172.18.0.18'
        option netmask '255.255.255.0'

config interface 'wan'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option profile '1'
        option ipv6 '1'
        option auth 'none'
        option modes 'all'
        option disabled '0'

and /etc/config/firewall:

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

are you sure your custom box, and (probably) custom OS supports ipv6 ?

Hi
Yes, I am sure of the support since using LTE vendor's command-line utility I am able to start the data call and ping google via IPv6 from the command-line.

of ..... ?

Of the custom Board