Custom dns wont work

Hi i have different vlan's in one of this one i've setup opendns to have a family filter for kids and worked like a charm since i upgraded to 19.07, now doesn't work anymore, i also tryed to reset the setting and manually setup everything again, but it doesn't work

I usually just use luci, i'm not so much expert with command line, so if you can help me with that it's awesome, but if terminal is needed i can ssh without problem

Does this config help?

I'm not so tech savy, could you please elaborate how can i do that on luci?

under the interface on the vlan i was used to write my custom dns on "Use custom DNS servers" seems logic and worked in the past

What I sent cannot be done on LuCI.

OK, cool. If you want to do it for the whole network, that will work too. Yes, you do add those on the WAN interface. You check that box, then only add DNS servers from OpenDNS. Also make sure you:

  • Only add DNS servers on the WAN setup, nowhere else
  • Restart the dnsmasq service (or reboot)
  • Reboot or clear the DNS cache of all downstream clients

Screenshot from 2020-01-16 17-02-12

I have 2 vlan one must be filtered, and the other one no, i think everythink will be filtered if i set the dns on the wan interface

1 Like

OK, so you wouldn't want that either...everyone would be filtered. Here's another option using LuCI:

  • If you don't mind loosing Local name resolution on the VLAN, you can use DHCP Option No. 6 to assign the alternative OpenDNS servers. Hopefully, this is what you're looking for:

writing in that box 6, wont work, should i write something more inside this box?

Why doesn't it work?

It defnately resoves DNS names:

user@machine:~$ nslookup

Non-authoritative answer:
Address: 2a03:b0c0:3:d0::1af1:1

You are aware you still need to:

In addition, you need to:

  • Obtain a new DHCP lease for all clients needing the new DNS config!

I tryed rebooting router and pc but it doesn't work, if i go using ssh on /etc/config/network i can see the dns entries i've inserted on "Use custom DNS servers" but for some strange reason doesn't seems to work

Ok now it works, i had to delete the dns entry on "Use custom DNS servers" and let alone the dhcp 6,

thanks for the help

Anyway i think there is a bug, because the "Use custom DNS servers" worked since a couple of years and now broked with the latest version, any chance devs do read this post or how can a bug be opened?

OK, I was making screenshots for you on a working device. Glad it's working for you!

I would add both servers:


No bug, you assigned it to a local network, not the WAN. The function you desire is not achieved by what you described. In fact, what you describe is a common mistake/misunderstanding on the forum.

LAN/VLAN DNS settings are only used by the router on requests originating from that network's IP. For the DNS settings to work globally, you'd assign them on WAN.

If you insist, can you show the config (from the past) and let me know the version. If it's not extremely old, I'll test what you claim.

I just tested, this works on 19.07.0.

High chance - but there are better ways to reach them (i.e. mailing list, IRC, and the developer's section on this site); but nothing's identified yet.

It work if you just use the default lan, but try to make a couple of vlan and something seems to screw up, i guessed an old imported config file was the issue but i've also done the config from zero all manual and at certain point i had the issue, at first time seemed a software update, so i've started again from zero but after a while even without updating the package i had this issue after a reboot


Packages updates are not recommended - they could soft brick your router and cause other quirky issues. If you want the most up-to-date software, flashing snapshot versions of the firmware are suggested instead.

Thanks for the info, anyway the issue with "Use custom DNS servers" is there even without updating

  • OK, as I noted in the strikethrough, I don't think the function was ever intended to work as you describe anyways
  • Unless I missed it, you never mentioned what previous version of OpenWrt this worked on

EDIT: And to be clear, you're stating that you assign different DNS servers to each interface; and clients on those networks would have their DNS looked up exclusively by the servers listed?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.