Custom builds - failing / bricking devices - searching for advice (Unifi AC Pro and Unifi AC light)


for some time I'm building my own images (latest snapshot from but recently after I upload custom build firmware, SSH is closing immediately connections, luci as well and naturally even the APs respond to pings, they are actually not working. So far I'm trying / failing just on Unifi AC Pro and Unifi AC light - even failsafe mode didn't work last time (same behavior - closing even SSH connections) and I had to upload factory images via TFTP....

Can someone please help me to understand how to prevent it or what is actually wrong ? I have it just as hobby, I'm not expert... unfortunately I don't want to open devices to see console, as they are still under warranty.... I just wonder, maybe the image is too big ? But why it does build successfully then...

binwalk --signature also extract related parts successfully.


Anything I can provide eventually from build logs ?
If needed, I can share also related .bin

Thank you.

Btw binwalk on latest snaphot I downloaded

moved to 'For Developers', custom builds and dynamic master code issues are beyond 'Installing and Using Openwrt'

if you have not 'clean'-ed or freshly setup source... this is a common thing to check first...

1 Like

Thank you, I'm doing "make clean" prior to each build ;-(

1 Like

Any guesses please anyone?

No logs, so this is really just some guesses.

Some guesses:

  • too big image. causing failure in the r/w overlay creation stage?

  • your config includes LOTS of packages & config settings. Start with a simple default image, and add features/options in gradual stages.

    I am now sure if your config output was your recipe or the output of ./scripts/ . In any case, quite a lot of settings & packages. (And the output of config differences, the diffconfig, would be much more useful than full .config)

  • Try without seccomp. That is still somewhat experimental...

1 Like

and if you have an old toolchain do a make dirclean as there was a change in the last while that manifested in interesting ways when an image was flashed.


Thank you all to your comments and ideas. I really appreciate it even we are kind of "blind" here.

Yes but shouldn't that be controlled by "max size" control / check ?

Hm I think I posted diffconfig, sorry for that - let me better repost it after recent modifications...

Hm, I don't recall I even enabled it - maybe it's turned on by default ? Anyway, disabled manually. Thank you.

Now I again used dirclean and rebuild it updating the tree.... I also enabled CONFIG_STRIP_KERNEL_EXPORTS and removed some DEBUG options - binwalk signature gives me : (seems "MySQL ISAM Index" appeared now", not sure what it is.....)

Flashing Unifi AC Light was successful, while Unifi AC Pro is not responding :wink: , I have to check tomorrow what has happened there (it's on the roof....) ;-(

That has been causing trouble sometimes.
See discussion starting from e.g. Dropbear crash - #7 by hnyman

You really should first start with empty .config, do a build with minimal config, and once that is successful, then start experimenting.

1 Like

Well I'm compiling myself Opemwrt for years, always used this option to get some additional space....I didn't know that setting is causing some issues now with latest versions, thank you for letting me know.

Anyway, the same config works now on Unifi AC Light but didn't work on Unifi AC Pro - actually after all the AC Pro device boot successfully but didn't get IP from my main router - so I reset the settings as actually also SSH worked fine (yes, I shall take logs...I was hoping problem has been resolved) and now I even can't access default IP...I will keep experimenting today, maybe recovery will be required or again flashing TFT Factory image.

Anyway, this whole topic was rather about "there isn't really some way to "test" fw prior flashing it" or how to check I did something wrong?
The reason I'm asking is that while I first update those AP in my reach, then rest of AP for my family
.. MR200, TPLinks 842, Archer C2 etc. but the recent builds are even not able to boot and yes, I know what are the risks of using development builds, that's not the point however. I have to use anyway some "minimal" config in those cases (eg. OpenVPN, Luci)...

So binwalk might be one of test, checking sizes of each segments (yet I don't know where to check right sizing, probably in initial device commits), extracting fw to see it's not damaged ....can I do even anything more then "just" this?

Thank you

So it seems I made some progress here, at least both APs are up (Unifi AP AC Pro and Unifi AP AC Lite).
Modifications I made :

  • I went back to separate config per device (from multi device option)
  • CONFIG_KERNEL_SECCOMP disabled as advised

So far seems that CONFIG_STRIP_KERNEL_EXPORTS didn't influence it (I run one AP with this disabled and 2nd with enabled).

Thank you to all.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.