Cudy WR3000 mesh slow shared 5G backhaul

Hi!

I am trying to replicate the OEM firmware mesh setup using OpenWrt and unfortunately I cannot solve slow 5G wifi problem.

OEM mesh setup uses 5G mesh backhaul and in the same time it uses 5G for WiFi clients, 2,4G too. When I test this setup using the same routers I have 150-210 Mbps on iperf3 on the route PC > Mesh Base > Mesh AP > Oppo Reno 6 Ping Tools iperf test. On 5G I have 450-500 Mbps.

With the same setup and the route on OpenWrt i have 100-180 Mbps on 2,4G, 180-200 Mbps on 5G. 2,4G generally works but 5G has some strange problems to like after a while iperf transfer is slowed down to 8 Mbps or i lost connection between PC and Smartphone.
When I connect directly to the Mesh Base I have about 550-700 Mbps on 5G.

I have tried to enable WED, it seems to increase speed when I connect directly to Mesh Base but no change with Mesh AP.

What is indeed interesting, backhaul works on 80 MHz channel despite 160 MHz configured.

I am using OpenWrt 24.10.0-rc5. Thank you for your help :slight_smile:

Here is my Mesh Base config:
/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd74:89c4:2a5c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.15.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '7'
        option band '2g'
        option htmode 'HE40'
        option txpower '20'
        option country 'PL'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '40'
        option band '5g'
        option htmode 'HE160'
        option txpower '23'
        option country 'PL'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'mesh'
        option encryption 'sae'
        option mesh_id 'AJC_mesh'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option key 'testpass'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk-mixed'
        option key 'testpass'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt_5G'
        option encryption 'psk-mixed'
        option key 'testpass'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan'
        option disabled '1'
root@OpenWrt:~# cat /sys/module/mt7915e/parameters/wed_enable 
Y

Mesh AP:
/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd83:c83a:bf78::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option band '2g'
        option channel '7'
        option htmode 'HE40'
        option cell_density '0'
        option txpower '20'
        option country 'PL'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option band '5g'
        option channel '40'
        option htmode 'HE160'
        option country 'PL'
        option cell_density '0'
        option txpower '23'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'mesh'
        option encryption 'sae'
        option mesh_id 'AJC_mesh'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option key 'testpass'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk-mixed'
        option key 'testpass'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan'

config wifi-iface 'wifinet4'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt_5G'
        option encryption 'psk-mixed'
        option key 'testpass'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan'
        option disabled '1'
root@OpenWrt:~# cat /sys/module/mt7915e/parameters/wed_enable 
Y

You should use 36 or 104 channel for 160MHz mesh

Also, check "force 40MHz" for 40Mhz on 2.4G

After setting force 40 MHz I have more stable 150-180 Mbps on iperf connected to mesh AP.

Channel 104 for 5G works with 160 MHz visible in associated stations. I have used ch 40 because it was used by OEM firmware (probably with 80 MHz width). Unfortunately on this setup I have similar bandwidth about 200 Mbps :frowning:

Can you post rx/tx rates for your phone from the web interface during speed test?

Looks ok
image
The problem with iperf3 looks like this. After about 30, maybe 45 minutes every test gives me the same result. I restarted iperf3 on my PC, restarted smartphone, nothing helped. Only Mesh Base restart helps.

you should try to downgrade to RC4

It is strange... I have installed 24.10.0-rc4 and
WED disabled - 350-400 Mbps on 5G, CH 40, 80 Mhz
WED disabled - 150-250 Mbps on 5G, CH 40, 80 Mhz
Well, something is wrong with RC5 :frowning: and RC4 too. WED seems to work on RC5 but not on RC4 but RC4 is generally faster without WED than RC5 with WED.
I will try to test a default OpenWrt from Cudy website too.

did you enable hw offload in config/web interface AND wed_enable=1 for kernel module?

Yep,

root@OpenWrt:~# cat /sys/module/mt7915e/parameters/wed_enable
Y

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

And with this setup I have 150-250 Mbps on RC4

Hi,
You can try bridger package. It is supposed to be used insted of WED on wifi nodes- check the Belkin RT3200 wiki.
I would remove all flow offloads and also try to setup AQL as per the GL MT6000 topic. The router is powerfull enough to work without offloads. Also check packed steering.
Kr
K