Cudy WR1300 V1 cant install packages for backdated kernel

Im currently using this latest built


I tried to install some packages ( luci-app-nft-qos and also some other packages) and im getting error like attached image.

It seems these packages requires a newer kernel version. I looked for updated kernel, but there is none available.

To get updated kernel, I tried to upgrade to latest snapshot build but after updating to snapshot I cant access openwrt with anymore. I tried many solutions but none of these helped.

Now Im back to stock for some times. But Now, how can I get new kernel update? Or, How can I install snapshot build? I tried flashing it twice but its the same, no access to luci.

Thanks in advance.
Sorry for my bad english.

Snapshots don't come with luci, need to manually install it post flash.

Install 22.03 stable from instead.

@frollic he is on cudy firmware

Yes right now I am on cudy firmware but i was on openwrt 22.03.2

Proper openwrt should be flashed via cudys openwrt.
Can't use/install "their" version, then use "our" packages.


well ok 22.03.2 cannot install software, that's new for me, but can be true

In 22.03.2 stable I cant install packages for having built in older kernel. The packages I want to install requires a new kernel. I tried to update packages but there were no kernel updates.

Are we talking about cudys openwrt, or the real thing?

I install Cudy's openwrt and than installed snapshot from Openwrt website.

Actually I emailed cudy, It seems updates from Openwrt website should work too.
Here is what they replied.

Of full openwrt + packages, not cudys openwrt and our packages.

Flash the 22.03.2 from here, running cudys 22.03, and you should be fine.

well i'm not sure if we are talking about openwrt here

Well let me explain easily.

I have installed openwrt provided by Cudy's website
this one, (for wr1300 v1)

after installing this this openwrt firmware, I cant install many packages becoz this firmware comes with an older kernel while those packages I want to install requires a new kernel (I mean my kernel is backdated)

So I waited for many days but there is no new kernel updates from Opkges. Now how can I have the new kernel that I'm looking for?

You can't.

If you use cudys openwrt, the packages will have to come from their repository, something they probably don't have. Out of lazyness they point to "our" instead, but those packages won't work, because of the error you're seeing.

1 Like

So should I just upgrade to this firmware using Cudy's Openwrt??

Besides for This firmware Hardware version (v1 or v2) is not mentioned.

Did you read the links provided earlier?

Support for v2 is new, only available in snapshots.

wr1300 = wr1300v1

1 Like

I see. I didnt knew support for v2 is not published yet. Thanks mate for your support. Ill try it tomorrow and let you know. Im still a noob so I screw up things often.

Another thing. How many write cycles can this 16mb SPI flash can sustain? Ive alreay written it quite a few times including going back to stock 3 times. Can it herm the emmc?

No idea, but you won't kill it just by reflashing it a cpl of times.

Good luck.

1 Like

do ot warry, sometime my devices are up for one month, sometime i flalsh it 100 times in a week when i try to change things

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.