Cudy WR1300 memory issue

I set up my cudy WR1300 router with the OpenWRT version they provide on their webpage. And now I'm wondering about memory (since I would like to install vpnc which always fails due to low memory):

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                13312     13312         0 100% /rom
tmpfs                    61780      3148     58632   5% /tmp
/dev/mtdblock7             832       300       532  36% /overlay
overlayfs:/overlay         832       300       532  36% /
tmpfs                      512         0       512   0% /dev

Package manangement tells:
Free space 63% (544.8KB)

Is there a way to reduce tempfs and increase /dev/mtdblock7?

Any help appreciated

/tmpfs is in RAM. It doesn't use any flash at all. You have a 13 MiB /rom (so the vendor firmware) tough and that looks rather fat. With a default OpenWrt image I reckon you'd be using far less.

Vendor firmwares based on OpenWrt are not supported here btw. You need to talk to your vendor for that.

.... or flash "our" version of openwrt.

Thanks for the quick answer. cudy provides two versions of firmware: their customized OpenWRT and a non-customized one. (I have installed this one: Powered by LuCI openwrt-19.07 branch (git-20.136.49537-fb2f363) / OpenWrt 19.07.3 r11063-85e04e9f46) I also tried to use one I downloaded from this page but I got an error message that it would not be the correct version. (I selected it from the hardware list for this router.)

I'd love to but I wasn't able to get it flashed. I will retry later and document the error message.

you can probably use their return to stock from openwrt instruction, to flash openwrt :wink:

it's TFTP based.

I tried this one:



Device cudy-wr1300 not supported by this image Supported devices: cudy,wr1300 - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA Image check failed.

I'll give it a try (after business hours). Will this solve the problem that I can't install the desired package or do I need to do something else? (E.g. mount extroot...)

install packages from our repository, yes.

But since WR1300 is currently only supported through snapshots ( = beta), read this:

This might be worth reading too: Cudy WR1300 support?

It literally says what you need to do. Use/tick 'force' with sysupgrade along with unticking 'keep configuration'. Respectively -F and -n on the command line.

19.07 uses swconfig and MT7621 uses DSA on 21.02 and master.

I just managed to compile my first firmware image and upload it to my router. And the router still works :wink:
Thanks for getting me on the track.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.