Cudy WR1300 config 'network' file

Hello,
I bought a router "Cudy WR 1300". I could download an OWrt Image from the develeloper but Iwas not able to make extroot with that Image. I think the Kernel was not up to date. So I could install a Snaphot I needed (luci, extroot,etc.) I thought everything went fine. Everything seems to work, but if I want to enter the network (device) section in luci a message appears:

Network bridge configuration migration

The existing network configuration needs to be changed for LuCI to function properly.

Upon pressing "Continue", bridges configuration will be moved from "interface" sections to "device" sections the network will be restarted to apply the updated configuration.

Once I clicked on the blue

Continue

Button and ended in mess. Now I started from the beginnining, everything seems to work, but I have that message, and cant enter devices in luci.

Maybe someone has a tip for me.

My network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config interface 'lan'
        option type 'bridge'
        option ifname 'br-lan wan'
        option proto 'static'
        option ipaddr '192.168.178.2'
        option gateway '192.168.178.122'
        list dns '192.168.178.122'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'
#       option type 'bridge'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

my wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11n'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT40'
        option channel '4'
        option cell_density '0'
        option country 'DE'
        option distance '7'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '108'
        option cell_density '0'
        option htmode 'VHT40'
        option country 'DE'
        option distance '7'
        option txpower '19'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'W-LAN3'
        option encryption 'psk2'
        option key '#############'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'W-LAN3-5G'
        option encryption 'psk2'
        option key '#############'
        option network 'lan'

config wifi-iface 'mesh'
        option device 'radio0'
        option mode 'mesh'
        option mesh_id 'W-LAN3-MESH'
        option key ##############'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option encryption 'sae'
        option max_inactivity '300'
        option network 'mesh5G'

config wifi-iface 'mesh5G'
        option device 'radio1'
        option mode 'mesh'
        option mesh_id 'W-LAN5-MESH'
        option key '##############'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option encryption 'sae'
        option max_inactivity '300'
        option network 'mesh5G'


config wifi-interface 'brmesh'
        option type 'bridge'
        option ifname 'lan mesh mesh5G'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'wan'

solved my Problem. Thx :grinning:

Thank you for sharing the result !

and OpenWrt 21.02.0-rc1 is running fine on this device :grinning:

Sorry can not find a Download link for 'ramips' ... Which architectur did you choose?

Or did you build yourself?

Here it is:
https://downloads.openwrt.org/releases/21.02.0-rc1/targets/ramips/mt7621/openwrt-21.02.0-rc1-ramips-mt7621-cudy_wr1300-squashfs-sysupgrade.bin

HTH

Nice, I will try it till next Weekend. Thank you :+1:t2:

You´re welcome