Cryptsetup-openssl package disappeared - what happened to it?

Hi guys & girls,

I have been (and still am) a happy user of davidc502's lede/openwrt build for my Linksys router. See:

In order to access my Veracrypt encrypted external hard disks I have always relied on the cryptsetup-openssl package. The non-openssl package just silently fails when I try to open my drives. Somewhat recently the cryptsetup-openssl package has disappeared from the OpenWrt daily builds. davidc502 does also not know what happened to this specific package.

Since it is integral to my setup I was wondering: does anyone know what happened to it?

Thank you for any help!



Thank you for that! Although it is really unfortunate as the regular package never had worked for me.

Never worked, or does not work with HD established by the openssl varaint. The recent git log would indicate another try may be in order if you want/need this faciltiy.

The hd was encrypted with regular Veracrypt. Regular cryptsetup on linux can also open it. It's just on OpenWrt that it silently fails (except for the openssl variant). That is true for versions up to 2.0.6, which is the last one that I tested.

However, version 2.1.0 might be interesting:

It states: This release also switches to OpenSSL as a default cryptographic
backend for LUKS header processing.

So it might be what I am looking for, not sure.