Creating software VLAN

Hello,

I use a router with one WAN port (eth0) and one LAN port (eth1) which is connected to unmanaged switch. I would like to connect my IPTV box also to this switch (now it is connected directly to ISPs modem), but it does not work (as it requires VLAN2000 to be set). I can view multicast streams from my ISP on computer (KODI) as I already configured igmpprxy, udpxy on router, but IPTV box does not work, because of this VLAN2000.

I am confused about how to procced with this VLAN2000 problem? Any suggestion?

My /etc/config/network looks like:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda9:d9a4:6fc6::/48'
        option packet_steering '1'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option igmp_snooping '1'

config device 'lan_eth1_dev'
        option name 'eth1'
        option macaddr 'aa:5a:96:16:8f:fe'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config device 'wan_eth0_dev'
        option name 'eth0'
        option macaddr 'aa:5a:96:16:8f:fd'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

First you should get a managed switch. Unmanaged switches have unpredictable behavior with tagged frames.

1 Like

agreed. Even if you can pass tagged frames on your unmanaged switch, it's still not appropriate for this usage, where the two VLANs need to remain separate.

With a managed switch you'd plug your ISP equipment into one port which would be a member of VLAN 2000 tagged... and then you'd make another port member of 2000 probably also tagged but maybe not depending on this TV box... and then plug that TV box into the second port.

2 Likes