Creating Multiple Isolated Wireless Networks on Archer C7 ver. 2

Hardware and Firmware: Archer C7 version 2 with the generic factory US firmware.
Objective: Creating multiple isolated wireless networks using 1 modem and 1 Archer C7. The goal is to have one network for my roommates and an isolated network for myself that I can play around with, without interrupting my roommates connection.

Attempt:
I've tried using default settings for lan, wan, and wan6 for one network and then creating virtual copies of those to assign to another network.

Question: Should I consider reaching my goal with an alternative method or is there a variation of what I've tried to do that might work?

After I tried the following setup and not being able to get variations of it to work for sometime, I went back to my default configuration for a single network by commenting out the virtual interfaces. My working default setup didn’t work again until I changed the lan address to something else. It seems that wan keeps being assigned to a similar range as lan.

Thanks for your time.

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxx:xxxx:xxxx::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0'

config interface 'vlan'
         option force_link '1'
         option type 'bridge'
         option proto 'static'
         option ipaddr '192.168.2.1'
         option netmask '255.255.255.0'
         option ip6assign '60'
         option ifname 'eth0.1'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth1'

config interface 'vwan'
      option proto 'dhcp'
      option ifname 'eth1.1'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth1'

config interface 'vwan6'
      option proto 'dhcpv6'
      option ifname 'eth1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 3 4 5 6'

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
         option interface 'lan'
         option start '100'
         option limit '150'
          option leasetime '12h'
          option dhcpv6 'server'
          option ra 'server'
          option ra_management '1'

config dhcp 'vlan'
        option interface 'vlan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config dhcp 'vwan'
        option interface 'vwan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

/etc/config/firewall (partial)

config defaults
        option syn_flood '1'
        option forward 'REJECT'
        option input 'ACCEPT'
        option output 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'vlan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'vlan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6'

config zone
        option name 'vwan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'vwan vwan6'

config forwarding
        option dest 'wan'
        option src 'lan'

config forwarding
        option dest 'vwan'
        option src 'lan'

this pretty much covers what you need, e.g. the guest network could become your roommates WiFi: https://lede-project.org/docs/user-guide/guestwifi_configuration
or in LuCi visual form: https://wiki.openwrt.org/doc/recipes/guest-wlan-webinterface

But the WiFi parts will not be completely independent: you can create several Wifis and underlying networks, but the WiFi parts cannot be operated 100% independently. The different WiFis will share the same WiFi channel and if you start/stop one of the virtual WiFi's, the others on the same channel will be interrupted as well for a few seconds, as the whole wireless service will be stopped and restarted, even if you just start/stop/update one of the virtual WiFi's configuration. I think even if you split on HW-layer and you use the 2.4GHz Wifi and your friend uses the 5 GHz Wifi, both WiFis might be interrupted for a few seconds, if you restart one of them.
But you should be able to mess with the firewall and network interface of your network part without interruption

Thanks, I managed to get that working.