My router only has a tiny amount of disc space, and I want to install python3-speedtest-cli.
I saw that this directory takes up a lot of space.
root@tplink650:/var/opkg-lists# du -hs .
924.0K .
root@tplink650:/var/opkg-lists# ls
openwrt_base openwrt_core.sig openwrt_packages openwrt_routing.sig
openwrt_base.sig openwrt_luci openwrt_packages.sig openwrt_telephony
openwrt_core openwrt_luci.sig openwrt_routing openwrt_telephony.sig
Can I removed these files?
Also /tmp
# du -hs /tmp
1020.0K /tmp
Where are the opkg packages downloaded to? I suspect some might need clearing up.
Although I flash the latest openwrt 23 onto this TPLink RE650, I know realise that it is does not have enough disc space to do any upgrades. What packages could I remove. Luci is an option, but I prefer to keep something for when I forget what I need to type I seem to recall the last opkg update && opkg upgrade ended up in zero disc space and failure.
Removing files from ramdisk will not free flas space, nor removing files from /overlay.
What have you upgraded to run out of space?
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
Your device does not seem to have USB support, so I guess you cannot use extroot. I think that your only option is to create your own image, and include only the essential packages.
Do you know why I could download the packages when I tried to do an upgrade, but it then ran out of space during the upgrade? Because I wondered if there were some pkgs left behind.
All I need to install is python3-speedtest-cli or something else that I can run speedtest on.
Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.
Sysupgrade to release keeping config
Install luci-app-attendedsysupgrade for all your upgrade needs.
If you have not noticed - no space for permanent packages BUT examine sysupgrade.conf for alternative.
In order to clean up the debris, one must know what packages were left behind, but I don't, because the mess was likely caused by a failed 'opkg upgrade'
Hence:
# ./opkg-rm-pkg-deps.sh
Downloading https://downloads.openwrt.org/releases/23.05.4/targets/ramips/mt7621/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading https://downloads.openwrt.org/releases/23.05.4/targets/ramips/mt7621/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/base/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/luci/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/routing/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading https://downloads.openwrt.org/releases/23.05.4/packages/mipsel_24kc/telephony/Packages.sig
Signature check passed.
opkg: the ``install'' command requires at least one argument
You need to reset to defaults. You can create a backup which will just grab your config -- you can then restore that easily after the reset.
Beyond that, you can use the firmware selector to create custom images that exclude some unnecessary packages and add in the ones you are hoping to include. Typically, the dependencies will all be handled automatically.
At a high level, what are you trying to add to your device?
I don't think the processor in that device is powerful enough to give you good performance with SQM unless you already have relatively limited speeds from your ISP. What are your ISP speeds?
And typically, it's best to simply use a general purpose computer/phone for your speed tests, rather than on-device (unless you have a fast processor, the speeds measured when the traffic is generated/terminated the router itself won't be representative of the speed at which it can route traffic through the device).
in the overlay partition of the flash memory (mounted as overlay or / as a read/write partition).
They're the same. LuCI is just a front-end user-interface for the underlying command line stuff.
You cannot free space removing files.
Reset router keeping configs to get rid of misguided upgrades.
Then install asu client and sysupgrade all at once.
You can make image in place using 30kB attended sysupgrade client, like remove pppoe if you never heard of it , or firewall on dumb ap. Dont overdo, hard to unbrick if you remove too much.
I don't think I need a f/w because this is all done on my Ubiquiti ER-X. Same for pppoe.
Although the firewall rules are still there, so I am not too sure ...
# awk '!/^#/' firewall|awk NF
config defaults
option syn_flood 1
option input REJECT
option output ACCEPT
option forward REJECT
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option dest_port 546
option family ipv6
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
You dont know yet, just avoid installing surplus after recovering flash space. You need firewall kmods for bridger ie fw offload on dumb AP.
Today recover space and do attended upgrade.