CPE210 V1.1 guest wifi on different VLAN

Hey there,

I've been using this AP on my roof for quite a while and at some point I decided to update to a recent OpenWRT release (22.03.3). However I couldn't make my guest wifi work again which is on a different VLAN (666). Do you have any ideas?

As it is a V1.x device, it still has two ethernet ports which I bridged because I have another device on the second port.

The old release (pre-DSA) had a switch configuration which I used and it worked fine. These are my old configurations

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ar934x_wmac'
	option htmode 'HT20'
	option legacy_rates '0'
	option country 'DE'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'XXX'
	option network 'lan'
	option encryption 'psk2+ccmp'
	option key 'XXX'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option network 'guest'
	option ssid 'YYY'
	option encryption 'none'

network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd41:44ad:de5f::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.8'

config interface 'guest'
        option proto 'static'
        option type 'bridge'
        option ifname 'eth0.666'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 5 4'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '666'
	option ports '0t 5t'

and these are the new ones. I won't get any network access when trying to join YYY. SSID XXX works fine and also if I attach YYY to the "lan" network I am also able to connect.

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '11'
	option band '2g'
	option htmode 'HT20'
	option country 'DE'
	option cell_density '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'XXX'
	option encryption 'psk2+ccmp'
	option key 'XXX'
	option network 'lan'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'YYY'
	option encryption 'none'
	option network 'guest'

network


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb8:25dd:eba0::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.8'
	option gateway '192.168.1.5'
	list dns '192.168.1.5'

config interface 'guest'
	option proto 'static'
	option device 'eth0.666'
	option delegate '0'


config device
	option name 'eth0'

I guess that is due to the missing switch configuration however I have no idea how that is handled now as all of it changed with DSA.

Got it working. The uplink is on eth1 so it should be eth1.666
I just created a new bridge with only one member eth1.666 , assigned that to the guest interface and the guest interface to the guest wifi.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.