CPE 210 Bridge Relayd AP WLan

Hi, everyone

I signed up here because I need help from Openwrt experts. I myself am not well acquainted with openwrt. But I have already set up a WA901ND according to instructions and unfortunately the instructions do not work on my CPE120 v1.

My problem:

I have a small WiFi transmitter (deep sounder) that sends data to a tablet on the shore, which is displayed in an app. The range of the WLAN transmitter is only 60m.

I would like to send the transmitter's WLAN to the tablet via the CPE210 V1 and thus increase the range.

The transmitter has an IP of 192.168.10.1 /255.255.255.0 and an active DHCP.
I installed the software relayd and luci-proto-relay on the CPE and changed the IP to 192.168.10.1 with Putty.
Due to lack of knowledge I can't configure the bridge and relayd + AP. The instructions from the WA901 do not work because the interface is different.

Could someone help me and guide me.

It is normal:

Device: WiFi to >>>>>>>> tablet with app
SSID Deeper Pro+ 81FF
IP:192.168.10.1 DHCP=on

New:

Device: Wifi to >>>>>> CPE210 Wifi >>>>>> to tablet with app
SSID Deeper Pro+ 81FF
IP:192.168.10.1 DHCP=on

Thanks for your help

Ps: sorry for my bad english i use google translator

Regards
Bruno

Hi, everyone,

I've been trying to configure my CPE210 for several days now, unfortunately without success.

I can configure the WA901 and the network works
The configuration then looks like this:


BusyBox v1.28.4 () built-in shell (ash)

 
root@OpenWrt:~# ubus call system board; \
 uci export network; uci export wireless; \
 uci export dhcp; uci export firewall; \
 head -n -0 /etc/firewall.user
{
        "kernel": "4.9.243",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros TP9343 rev 0",
        "model": "TP-Link TL-WA901N\/ND v5",
        "board_name": "tl-wa901nd-v5",
        "release": {
                "distribution": "OpenWrt",
                "version": "18.06.9",
                "revision": "r8077-7cbbab7246",
                "target": "ar71xx\/tiny",
                "description": "OpenWrt 18.06.9 r8077-7cbbab7246"
        }
}
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd02:f9bc:d4dc::/48'
		
		
		
		
		
		
config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.10.1'
        option dns '255.255.255.0'

config interface 'WWAN'
        option proto 'dhcp'
        option ifname 'eth0'

config interface 'LANrelayd'
        option proto 'static'
        option ifname 'eth0'
        option type 'bridge'

config interface 'BRIDGErelayd'
        option proto 'relay'
        list network 'LANrelayd'
        list network 'wwan'

config interface 'wwan'
        option proto 'dhcp'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option htmode 'HT20'
        option disabled '0'
        option country 'US'
        option legacy_rates '1'
        option channel '1'
        option txpower '26'

config wifi-iface
        option network 'wwan'
        option ssid 'Deeper PRO+ 81FF'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid '00:9D:6B:64:81:FF'
        option key '12345678'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'Deeper PRO+ 82FF'
        option network 'LANrelayd'
        option encryption 'psk2'
        option key '12345678'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan WWAN LANrelayd wwan BRIDGErelayd'

config include
        option path '/etc/firewall.user'>

On the CPE 210 I cannot configure it via LUCI. I assume it works. But I don't know what I'm doing wrong. I installed the software relayd and luci-proto-relay as well as on the WA901.
The configuration looks like this:

>BusyBox v1.33.2 (2022-04-16 12:59:34 UTC) built-in shell (ash)<

  _______                     ________        __

 >OpenWrt 21.02.3, r16554-1d4dea6d4f<
 -----------------------------------------------------

root@OpenWrt:~# ubus call system board; \
 uci export network; uci export wireless; \
 uci export dhcp; uci export firewall; \
 head -n -0 /etc/firewall.user
{
        "kernel": "5.4.188",
        "hostname": "OpenWrt",
        "system": "Atheros AR9344 rev 2",
        "model": "TP-Link CPE210 v1",
        "board_name": "tplink,cpe210-v1",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.3",
                "revision": "r16554-1d4dea6d4f",
                "target": "ath79/generic",
                "description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2e:294a:9a92::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.10.1'
        list dns '255.255.255.0'

config interface 'LANrelayd'
        option proto 'static'
        option device 'eth0'
        option type 'bridge'

config interface 'wwan'
        option proto 'dhcp'

config interface 'BRIDGErelayd'
        option proto 'relay'
        list network 'LANrelayd'
        list network 'wwan'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Deeper PRO+ 81FF'
        option encryption 'psk2'
        option key '12345678'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Deeper PRO+ 82FF'
        option encryption 'psk2'
        option hidden '1'
        option key '12345678'
        option network 'LANrelayd'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list network 'LANrelayd'
        list network 'wwan'
        list network 'BRIDGErelayd'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

<config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled 'false'

<config include>
        option path '/etc/firewall.user'>

Konnte mir jemand helfen?

Grüße
Bruno