Country inconsistency?

Hello, I have set the country channel correctly (IT) but if from cmd: iw reg get I get as Country = US. Why this?
1 2


I am having several problems on the automatic 5Ghz channel setting that goes on the 149 for no reason.

Seem the same problem explained HERE

Device : TP-Link Archer C7 v5 + OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-20.247.75781-0d0ab01

[    0.000000] Linux version 4.14.195 (builder@buildhost) (gcc version 7.5.0 (OpenWrt GCC 7.5.0 r11208-ce6496d796)) #0 Sun Sep 6 16:19:39 2020
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] MIPS: machine is TP-Link Archer C7 v5
[    0.000000] SoC: Qualcomm Atheros QCA956X ver 1 rev 0
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] On node 0 totalpages: 32768
[    0.000000] free_area_init_node: node 0, pgdat 804fbf70, node_mem_map 810090a0
[    0.000000]   Normal zone: 256 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 32768 pages, LIFO batch:7
[    0.000000] random: get_random_bytes called from 0x804ff740 with crng_init=0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 123296K/131072K available (4031K kernel code, 160K rwdata, 532K rodata, 1220K init, 212K bss, 7776K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] CPU clock: 775.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4932285024 ns
[    0.000008] sched_clock: 32 bits at 387MHz, resolution 2ns, wraps every 5541893118ns
[    0.008236] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[    0.074782] pid_max: default: 32768 minimum: 301
[    0.079802] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.086787] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.097898] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.108293] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.114786] pinctrl core: initialized pinctrl subsystem
[    0.122335] NET: Registered protocol family 16
[    0.129821] PCI host bridge /ahb/pcie-controller@18250000 ranges:
[    0.136299]  MEM 0x0000000012000000..0x0000000013ffffff
[    0.141801]   IO 0x0000000000000000..0x0000000000000000
[    0.162043] PCI host bridge to bus 0000:00
[    0.166369] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
[    0.173655] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.179525] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.186689] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.195059] pci 0000:00:00.0: [168c:003c] type 00 class 0x028000
[    0.195111] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
[    0.195163] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    0.195235] pci 0000:00:00.0: supports D1 D2
[    0.195410] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    0.195433] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[    0.203183] pci 0000:00:00.0: BAR 6: assigned [mem 0x12200000-0x1220ffff pref]
[    0.213345] clocksource: Switched to clocksource MIPS
[    0.219556] NET: Registered protocol family 2
[    0.224918] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.232272] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.239026] TCP: Hash tables configured (established 1024 bind 1024)
[    0.245865] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.252033] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.258889] NET: Registered protocol family 1
[    0.263556] PCI: CLS 0 bytes, default 32
[    0.266080] Crashlog allocated RAM at address 0x3f00000
[    0.272714] workingset: timestamp_bits=30 max_order=15 bucket_order=0
[    0.283835] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.289977] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.308605] io scheduler noop registered
[    0.312741] io scheduler deadline registered (default)
[    0.318507] ar7200-usb-phy usb-phy: phy reset is missing
[    0.325631] pinctrl-single 1804002c.pinmux: 544 pins at pa b804002c size 68
[    0.333452] gpio-export gpio-export: 1 gpio(s) exported
[    0.339679] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.348462] console [ttyS0] disabled
[    0.352262] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 1562500) is a 16550A
[    0.361395] console [ttyS0] enabled
[    0.368963] bootconsole [early0] disabled
[    0.394662] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.399574] 8 fixed-partitions partitions found on MTD device spi0.0
[    0.406155] Creating 8 MTD partitions on "spi0.0":
[    0.411108] 0x000000000000-0x000000020000 : "factory-uboot"
[    0.417560] 0x000000020000-0x000000040000 : "u-boot"
[    0.423298] 0x000000040000-0x000000050000 : "partition-table"
[    0.429918] 0x000000050000-0x000000060000 : "art"
[    0.435473] 0x000000060000-0x000000080000 : "info"
[    0.441050] 0x000000080000-0x0000000c0000 : "user-config"
[    0.447314] 0x0000000c0000-0x000000fc0000 : "firmware"
[    0.456981] 2 uimage-fw partitions found on MTD device firmware
[    0.463104] Creating 2 MTD partitions on "firmware":
[    0.468279] 0x000000000000-0x000000185f97 : "kernel"
[    0.474058] 0x000000185f97-0x000000f00000 : "rootfs"
[    0.479752] mtd: device 8 (rootfs) set to be root filesystem
[    0.485699] 1 squashfs-split partitions found on MTD device rootfs
[    0.492090] 0x000000440000-0x000000f00000 : "rootfs_data"
[    0.498293] 0x000000ff0000-0x000001000000 : "default-config"
[    0.505788] libphy: Fixed MDIO Bus: probed
[    1.183698] libphy: ag71xx_mdio: probed
[    1.190663] switch0: Atheros AR8337 rev. 2 switch registered on mdio-bus.0
[    1.844867] ag71xx 19000000.eth: connected to PHY at mdio-bus.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]
[    1.856466] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: sgmii
[    1.865514] NET: Registered protocol family 10
[    1.875347] Segment Routing with IPv6
[    1.879222] NET: Registered protocol family 17
[    1.883905] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.897304] 8021q: 802.1Q VLAN Support v1.8
[    1.903622] hctosys: unable to open rtc device (rtc0)
[    1.914389] VFS: Mounted root (squashfs filesystem) readonly on device 31:8.
[    1.928312] Freeing unused kernel memory: 1220K
[    1.932991] This architecture does not have kernel memory protection.
[    2.552856] init: Console is alive
[    2.556638] init: - watchdog -
[    2.563382] random: fast init done
[    3.606666] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.837841] usbcore: registered new interface driver usbfs
[    3.843642] usbcore: registered new interface driver hub
[    3.849201] usbcore: registered new device driver usb
[    3.859793] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.867976] ehci-platform: EHCI generic platform driver
[    3.873644] ehci-platform 1b000000.usb: EHCI Host Controller
[    3.879534] ehci-platform 1b000000.usb: new USB bus registered, assigned bus number 1
[    3.887735] ehci-platform 1b000000.usb: irq 13, io mem 0x1b000000
[    3.923389] ehci-platform 1b000000.usb: USB 2.0 started, EHCI 1.00
[    3.930498] hub 1-0:1.0: USB hub found
[    3.934722] hub 1-0:1.0: 1 port detected
[    3.939787] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    3.957688] init: - preinit -
[    5.071755] random: jshn: uninitialized urandom read (4 bytes read)
[    5.311842] random: jshn: uninitialized urandom read (4 bytes read)
[    5.563027] random: jshn: uninitialized urandom read (4 bytes read)
[    6.928335] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    6.934480] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[    6.973652] urandom_read: 4 callbacks suppressed
[    6.973659] random: procd: uninitialized urandom read (4 bytes read)
[    7.954670] eth0: link up (1000Mbps/Full duplex)
[    7.959524] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    7.966325] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   10.217066] jffs2: notice: (507) jffs2_build_xattr_subsystem: complete building xattr subsystem, 8 of xdatum (3 unchecked, 5 orphan) and 87 of xref (21 dead, 0 orphan) found.
[   10.235485] mount_root: switching to jffs2 overlay
[   10.261236] overlayfs: upper fs does not support tmpfile.
[   10.274652] urandom-seed: Seeding with /etc/urandom.seed
[   10.383890] eth0: link down
[   10.405448] procd: - early -
[   10.408519] procd: - watchdog -
[   11.081919] procd: - watchdog -
[   11.085478] procd: - ubus -
[   11.145703] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.153848] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.161580] procd: - init -
[   12.379277] urngd: v1.0.2 started.
[   12.502324] random: crng init done
[   12.761770] kmodloader: loading kernel modules from /etc/modules.d/*
[   12.795634] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   12.822132] Loading modules backported from Linux version v4.19.137-0-gc076c79e03c6
[   12.830098] Backport generated by backports.git v4.19.137-1-0-g60c3a249
[   12.855399] ip_tables: (C) 2000-2006 Netfilter Core Team
[   12.880306] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
[   12.981308] xt_time: kernel timezone is -0000
[   13.088057] PPP generic driver version 2.4.2
[   13.104448] NET: Registered protocol family 24
[   13.599492] ath10k 4.19 driver, optimized for CT firmware, probing pci device: 0x3c.
[   13.625197] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[   13.631227] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[   14.008131] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:00:00.0.txt failed with error -2
[   14.019047] ath10k_pci 0000:00:00.0: Falling back to user helper
[   14.164660] firmware ath10k!fwcfg-pci-0000:00:00.0.txt: firmware_loading_store: map pages failed
[   14.174045] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with error -2
[   14.185135] ath10k_pci 0000:00:00.0: Falling back to user helper
[   14.362257] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed
[   14.374684] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-5.bin failed with error -2
[   14.386067] ath10k_pci 0000:00:00.0: Falling back to user helper
[   14.563558] firmware ath10k!QCA988X!hw2.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
[   14.573395] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-2.bin failed with error -2
[   14.584733] ath10k_pci 0000:00:00.0: Falling back to user helper
[   14.767392] firmware ath10k!QCA988X!hw2.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
[   14.777220] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2
[   14.788303] ath10k_pci 0000:00:00.0: Falling back to user helper
[   14.975769] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
[   14.985332] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with error -2
[   14.996417] ath10k_pci 0000:00:00.0: Falling back to user helper
[   15.178232] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed
[   15.187816] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-4.bin failed with error -2
[   15.198905] ath10k_pci 0000:00:00.0: Falling back to user helper
[   15.376238] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed
[   15.385803] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with error -2
[   15.396894] ath10k_pci 0000:00:00.0: Falling back to user helper
[   15.575139] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed
[   15.869526] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[   15.879099] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[   15.891512] ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-8x-__fW-022-538f0906 api 2 features wmi-10.x,has-wmi-mgmt-tx,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT crc32 e1c91a74
[   15.944686] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
[   15.955497] ath10k_pci 0000:00:00.0: Falling back to user helper
[   16.052665] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
[   16.062929] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[   17.471163] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
[   17.488750] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
[   17.495205] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
[   17.503511] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20984 iram: 25656'
[   17.572369] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 2 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1
[   17.585376] ath10k_pci 0000:00:00.0: NOTE:  Firmware DBGLOG output disabled in debug_mask: 0x10000000
[   17.836573] ath: EEPROM regdomain: 0x0
[   17.836580] ath: EEPROM indicates default country code should be used
[   17.836583] ath: doing EEPROM country->regdmn map search
[   17.836595] ath: country maps to regdmn code: 0x3a
[   17.836600] ath: Country alpha2 being used: US
[   17.836603] ath: Regpair used: 0x3a
[   17.900634] ath: EEPROM regdomain: 0x0
[   17.900642] ath: EEPROM indicates default country code should be used
[   17.900644] ath: doing EEPROM country->regdmn map search
[   17.900657] ath: country maps to regdmn code: 0x3a
[   17.900662] ath: Country alpha2 being used: US
[   17.900665] ath: Regpair used: 0x3a
[   17.913032] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   17.914722] ieee80211 phy1: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
[   17.961462] kmodloader: done loading kernel modules from /etc/modules.d/*
[   28.465281] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   28.472731] eth0: link up (1000Mbps/Full duplex)
[   28.493557] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   28.506746] br-lan: port 1(eth0.1) entered blocking state
[   28.512331] br-lan: port 1(eth0.1) entered disabled state
[   28.518238] device eth0.1 entered promiscuous mode
[   28.523189] device eth0 entered promiscuous mode
[   28.603458] br-lan: port 1(eth0.1) entered blocking state
[   28.609047] br-lan: port 1(eth0.1) entered forwarding state
[   28.614993] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   29.474763] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   31.024974] ath: EEPROM regdomain: 0x817c
[   31.029122] ath: EEPROM indicates we should expect a country code
[   31.035465] ath: doing EEPROM country->regdmn map search
[   31.040948] ath: country maps to regdmn code: 0x37
[   31.045916] ath: Country alpha2 being used: IT
[   31.050499] ath: Regpair used: 0x37
[   31.054121] ath: regdomain 0x817c dynamically updated by user
[   31.060125] ath: EEPROM regdomain: 0x817c
[   31.064286] ath: EEPROM indicates we should expect a country code
[   31.070569] ath: doing EEPROM country->regdmn map search
[   31.076072] ath: country maps to regdmn code: 0x37
[   31.081017] ath: Country alpha2 being used: IT
[   31.085621] ath: Regpair used: 0x37
[   31.089235] ath: regdomain 0x817c dynamically updated by user
[   32.626333] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[   32.756283] br-lan: port 2(wlan1) entered blocking state
[   32.761782] br-lan: port 2(wlan1) entered disabled state
[   32.767574] device wlan1 entered promiscuous mode
[   35.814905] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
[   35.832545] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
[   35.838816] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
[   35.847721] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20984 iram: 25656'
[   36.077447] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
[   36.109481] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   36.197548] br-lan: port 3(wlan0) entered blocking state
[   36.203142] br-lan: port 3(wlan0) entered disabled state
[   36.208956] device wlan0 entered promiscuous mode
[   45.769096] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[   45.775884] br-lan: port 2(wlan1) entered blocking state
[   45.781379] br-lan: port 2(wlan1) entered forwarding state
[  100.667131] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  100.673919] br-lan: port 3(wlan0) entered blocking state
[  100.679429] br-lan: port 3(wlan0) entered forwarding state

Thanks

1 Like

Do you have the US version or the EU version of the archer c7 v5?

On the box EU Version. Same the device enclosure.

Do you have channel 149 accessible on openwrt? (Band 4)

Yes
1

1 Like

Set it to 149 and see if you can broadcast and start the wifi network in that domain. see if the status shows a signal after changing the channel and restarting the router normally.

Check if your devices detect the wifi network at channel 149.

ART(Atheros Radio Test) Partition sets the country codes, which is read only by default.

I have the same "issue"

iw reg get
global
country CH: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#1
country US: DFS-FCC
	(2402 - 2472 @ 40), (N/A, 30), (N/A)
	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
	(2402 - 2472 @ 40), (N/A, 30), (N/A)
	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57240 - 71000 @ 2160), (N/A, 40), (N/A)

But I notice not a problem. Can you explain why it is not good to have here US?
Why is this a bug? For me everything workiing

1 Like

What is the country code mentioned in your router label and box?

I don't know. But bought the product in Swiss online shop.

Look for the country code at the bottom of the router. It must be mentioned as Archer C7 v5.0 (EU) or (US) or (your ISP if they are a major player in your region)

1 Like

Thank you for explanation. It's EU.

1 Like

Each country (or region) has different regulations. If your router is configured for another region, it will try to enforce regulations not applicable to your country.

You could be transmitting on forbidden channels, or with an excessive power, or perhaps the other way around.

3 Likes

Same for my TP-Link C2600, also a Euro version:

root@router:~# iw reg get
global
country SI: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#1
country US: DFS-FCC
	(2402 - 2472 @ 40), (N/A, 30), (N/A)
	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
	(2402 - 2472 @ 40), (N/A, 30), (N/A)
	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57240 - 71000 @ 2160), (N/A, 40), (N/A)

Reg domains were always a bit of a mess.

Based on your screenshot, I see you had channel 52 set, which is a DFS channel in Europe. Do you have a DFS CAC Scan message in your log? tl;dr If your router detects a weather scanning array (or some other powerful transmission) on that channel, it will auto-switch to a non-dfs channel. If this is happening, you'll have two log lines: One for scan start, and one for radar detection and switch.

Something like this:

Sat Oct 31 15:07:34 2020 daemon.notice hostapd: wlan1: interface state HT_SCAN->DFS
Sat Oct 31 15:07:34 2020 daemon.notice hostapd: wlan1: DFS-CAC-START freq=5260 chan=52 sec_chan=1, width=0, seg0=0, seg1=0, cac_time=60s
Sat Oct 31 15:08:36 2020 daemon.notice hostapd: wlan1: DFS-CAC-COMPLETED success=1 freq=5260 ht_enabled=1 chan_offset=1 chan_width=2 cf1=5270 cf2=0
1 Like

Seem to work!
1 2 3

1 Like