Could not open disk cache file /var/pdnsd/pdnsd.cache

pdnsd[1910]: Could not open disk cache file /var/pdnsd/pdnsd.cache: No such file or directory
pdnsd[1910]: Error: could not bind socket: Permission denied. Status readback will be impossible
  • Are you asking for help?
  • Are you aware that the last code edit was 7 years ago?
  • Have you inquired with the developer?
  • Have you tried the site listed on the Wikipedia page?
  • Did you actually create the folder /var/pdnsd ..that folder is not persistent on OpenWrt??? You must create it on each boot before pdnsd runs.
  • If pdnsd requires the file pdnsd.cache to preexist, you also have to use touch to make it as well
1 Like

@lleachii Thank you, I think fixed it.

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.