Could not find the php7-mod-curl for lede

Hi, I try to using next cloud on my openwrt device. And the next cloud needs php-mod-curl. I could not find this package in lede. My device is Sunxi (A 20). and I try to Compile it myself but it have errors below:

configure: error: Cannot find OpenSSL's <evp.h>
make[2]: *** [/opt/source/sunxi/lede-sdk-17.01.4-sunxi_gcc-5.4.0_musl-1.1.16_eabi.Linux-x86_64/build_dir/target-arm_cortex-a8+vfpv3_musl-1.1.16_eabi/php-7.1.1/.configured_nnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnyynyn] Error 1

I had been installed openssl-dev on my environment. I had tried ubuntu 12 14 Debian 9 and also installed openssl-dev openssl in the above three os. but still the same.

I look at the php make file:

ifneq ($(SDK)$(CONFIG_PACKAGE_php7-mod-openssl),)
        --with-openssl=shared,"$(STAGING_DIR)/usr" \
        --with-kerberos=no \
  CONFIGURE_ARGS+= --without-openssl

and in the staging_dir mkdir /usr/include and link
/usr/include/openssl in that folder but still error.

can someone help me ? or tell me how to download php7-mod-curl ? thanks .

It looks like you need it for the cross-compile environment. Does your package Makefile include a dependency on the OpenSSL libraries?

I using lede-sdk-17.01.4-sunxi_gcc-5.4.0_musl-1.1.16_eabi.Linux-x86_64 sdk package to compile php7. I just need php7-mod-curl. I don't know where to place the evp.h header file. I compile by using make package/php7/compile V=99 and the php7 is come from openwrt 's package GitHub :

I typically do my compiles within the structure of the "standard" build environment rather than trying to use the toolchain it creates on its own.

When I look at the Makefile for OpenSSH, for example, it adds DEPENDS:=+libopenssl (among other things).

Yes I am trying to build my own cross-compile environmental. and now still downloading files. it is very slow in my country for a lot of reasons :slightly_frowning_face: and I had been waiting for a whole day.