Could not find PHY for device 'radio0'

Hi everyone, new to OpenWRT so I'm not sure if this is a dumb question, but I've been trying to diagnose this issue for a few hours with no success. Probably due to me having no idea how to describe the issue I'm having.

So I just installed OpenWRT SNAPSHOT r10574-273b803623 on my D-Link DIR510-L and got it (mostly) up and running. I'm just having issues with Radio0, specifically, I can't seem to select a mode, band, channel, etc, and so I think this is leading to me getting a "wireless is not associated" error message which is leading to me not being able to connect to the radio.

Radio1 is working fine and, checking the config/wireless file, the two radios are set up almost identically, except for the path.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'
        option disabled '0'
        option disable '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt1'
        option encryption 'psk2'
        option key 'TestTest1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option disabled '0'
        option disable '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt2'
        option encryption 'psk2'
        option key 'TestTest1'

And here are the recent system logs. Getting a fair few errors surrounding Radio0 but I don't really know what they mean... Let me know if you want the kernel logs too.

Wed Jul 31 11:01:03 2019 daemon.notice netifd: radio0 (4492): Could not find PHY for device 'radio0'
Wed Jul 31 11:01:03 2019 daemon.notice netifd: radio0 (4500): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 11:01:52 2019 daemon.notice netifd: radio0 (4712): Could not find PHY for device 'radio0'
Wed Jul 31 11:01:52 2019 daemon.notice netifd: radio0 (4727): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 11:03:29 2019 authpriv.info dropbear[1300]: Exit (root): Keepalive timeout
Wed Jul 31 11:04:29 2019 authpriv.info dropbear[2514]: Exit (root): Exited normally
Wed Jul 31 11:08:25 2019 daemon.notice netifd: radio0 (5451): Could not find PHY for device 'radio0'
Wed Jul 31 11:08:25 2019 daemon.notice netifd: radio0 (5459): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 11:09:56 2019 authpriv.info dropbear[1890]: Exit (root): Keepalive timeout
Wed Jul 31 11:11:01 2019 authpriv.info dropbear[5567]: Child connection from 192.168.1.111:61264
Wed Jul 31 11:11:05 2019 authpriv.notice dropbear[5567]: Password auth succeeded for 'root' from 192.168.1.111:61264
Wed Jul 31 11:11:48 2019 authpriv.info dropbear[5567]: Exit (root): Exited normally
Wed Jul 31 11:15:24 2019 daemon.info dnsmasq-dhcp[2393]: DHCPDISCOVER(br-lan) 192.168.1.15 bc:5f:f4:46:46:86
Wed Jul 31 11:15:24 2019 daemon.info dnsmasq-dhcp[2393]: DHCPOFFER(br-lan) 192.168.1.143 bc:5f:f4:46:46:86
Wed Jul 31 11:15:24 2019 daemon.info dnsmasq[2393]: read /etc/hosts - 4 addresses
Wed Jul 31 11:15:24 2019 daemon.info dnsmasq[2393]: read /tmp/hosts/odhcpd - 3 addresses
Wed Jul 31 11:15:24 2019 daemon.info dnsmasq[2393]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Wed Jul 31 11:15:24 2019 daemon.info dnsmasq-dhcp[2393]: read /etc/ethers - 0 addresses
Wed Jul 31 11:15:24 2019 daemon.info dnsmasq-dhcp[2393]: DHCPREQUEST(br-lan) 192.168.1.15 bc:5f:f4:46:46:86
Wed Jul 31 11:15:24 2019 daemon.info dnsmasq-dhcp[2393]: DHCPNAK(br-lan) 192.168.1.15 bc:5f:f4:46:46:86 wrong server-ID
Wed Jul 31 11:24:22 2019 daemon.notice netifd: radio0 (6948): Could not find PHY for device 'radio0'
Wed Jul 31 11:24:22 2019 daemon.notice netifd: radio0 (6956): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 11:25:47 2019 daemon.notice netifd: radio0 (7165): Could not find PHY for device 'radio0'
Wed Jul 31 11:25:48 2019 daemon.notice netifd: radio0 (7180): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 11:30:21 2019 authpriv.info dropbear[7782]: Child connection from 192.168.1.111:59244
Wed Jul 31 11:30:26 2019 authpriv.notice dropbear[7782]: Password auth succeeded for 'root' from 192.168.1.111:59244
Wed Jul 31 11:40:01 2019 authpriv.info dropbear[7782]: Exit (root): Exited normally
Wed Jul 31 11:42:28 2019 daemon.notice netifd: radio0 (9307): Could not find PHY for device 'radio0'
Wed Jul 31 11:42:28 2019 daemon.notice netifd: radio0 (9322): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 11:44:59 2019 authpriv.info dropbear[9626]: Child connection from 192.168.1.111:59717
Wed Jul 31 11:45:04 2019 authpriv.notice dropbear[9626]: Password auth succeeded for 'root' from 192.168.1.111:59717
Wed Jul 31 11:53:22 2019 daemon.notice netifd: radio0 (11306): Could not find PHY for device 'radio0'
Wed Jul 31 11:53:23 2019 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Wed Jul 31 11:53:23 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 7c:2a:31:0b:e4:b5
Wed Jul 31 11:53:23 2019 daemon.notice hostapd: wlan0: AP-DISABLED
Wed Jul 31 11:53:23 2019 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Wed Jul 31 11:53:23 2019 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Wed Jul 31 11:53:23 2019 kern.info kernel: [ 2033.765308] device wlan0 left promiscuous mode
Wed Jul 31 11:53:23 2019 kern.info kernel: [ 2033.774469] br-lan: port 2(wlan0) entered disabled state
Wed Jul 31 11:53:23 2019 daemon.notice netifd: Network device 'wlan0' link is down
Wed Jul 31 11:53:24 2019 user.notice mac80211: Failed command: iw phy phy0 set antenna 0xffffffff 0xffffffff
Wed Jul 31 11:53:24 2019 daemon.notice netifd: radio1 (11360): command failed: Not supported (-122)
Wed Jul 31 11:53:24 2019 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Wed Jul 31 11:53:24 2019 daemon.notice netifd: radio1 (11360): sh: out of range
Wed Jul 31 11:53:24 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Wed Jul 31 11:53:26 2019 kern.info kernel: [ 2035.309963] ieee80211 phy0: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration start
Wed Jul 31 11:53:26 2019 kern.info kernel: [ 2035.326564] ieee80211 phy0: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration end
Wed Jul 31 11:53:26 2019 kern.info kernel: [ 2037.185311] ieee80211 phy0: rt2800_loft_iq_calibration: Info - LOFT Calibration Done!
Wed Jul 31 11:53:26 2019 kern.info kernel: [ 2037.204709] ieee80211 phy0: rt2800_iq_search: Info - IQCalibration Start!
Wed Jul 31 11:53:26 2019 kern.info kernel: [ 2037.232648] ieee80211 phy0: rt2800_iq_search: Info - IQCalibration Done! CH = 0, (gain= 1, phase= 2)
Wed Jul 31 11:53:26 2019 kern.info kernel: [ 2037.251777] ieee80211 phy0: rt2800_iq_search: Info - IQCalibration Start!
Wed Jul 31 11:53:26 2019 kern.info kernel: [ 2037.279236] ieee80211 phy0: rt2800_iq_search: Info - IQCalibration Done! CH = 1, (gain= 3, phase=3c)
Wed Jul 31 11:53:26 2019 kern.info kernel: [ 2037.297476] ieee80211 phy0: rt2800_loft_iq_calibration: Info - TX IQ Calibration Done!
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.326636] ieee80211 phy0: rt2800_rxiq_calibration: Info - RXIQ G_imb=0, Ph_rx=-3
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.351998] ieee80211 phy0: rt2800_rxiq_calibration: Info - RXIQ G_imb=3, Ph_rx=0
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.376771] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.394825] br-lan: port 2(wlan0) entered blocking state
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.405492] br-lan: port 2(wlan0) entered disabled state
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.416485] device wlan0 entered promiscuous mode
Wed Jul 31 11:53:27 2019 daemon.err hostapd: Using interface wlan0 with hwaddr 78:54:2e:9d:4b:da and ssid "OpenWrt2"
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.940929] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.953861] br-lan: port 2(wlan0) entered blocking state
Wed Jul 31 11:53:27 2019 kern.info kernel: [ 2037.964498] br-lan: port 2(wlan0) entered forwarding state
Wed Jul 31 11:53:27 2019 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->ENABLED
Wed Jul 31 11:53:27 2019 daemon.notice hostapd: wlan0: AP-ENABLED
Wed Jul 31 11:53:27 2019 daemon.notice netifd: Network device 'wlan0' link is up
Wed Jul 31 11:53:29 2019 daemon.info hostapd: wlan0: STA 7c:2a:31:0b:e4:b5 IEEE 802.11: authenticated
Wed Jul 31 11:53:29 2019 daemon.info hostapd: wlan0: STA 7c:2a:31:0b:e4:b5 IEEE 802.11: associated (aid 1)
Wed Jul 31 11:53:29 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 7c:2a:31:0b:e4:b5
Wed Jul 31 11:53:29 2019 daemon.info hostapd: wlan0: STA 7c:2a:31:0b:e4:b5 WPA: pairwise key handshake completed (RSN)
Wed Jul 31 11:53:29 2019 daemon.info dnsmasq-dhcp[2393]: DHCPREQUEST(br-lan) 192.168.1.111 7c:2a:31:0b:e4:b5
Wed Jul 31 11:53:29 2019 daemon.info dnsmasq-dhcp[2393]: DHCPACK(br-lan) 192.168.1.111 7c:2a:31:0b:e4:b5 Laptop-Nicolas
Wed Jul 31 11:53:29 2019 daemon.info dnsmasq[2393]: read /etc/hosts - 4 addresses
Wed Jul 31 11:53:29 2019 daemon.info dnsmasq[2393]: read /tmp/hosts/odhcpd - 2 addresses
Wed Jul 31 11:53:29 2019 daemon.info dnsmasq[2393]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Wed Jul 31 11:53:29 2019 daemon.info dnsmasq-dhcp[2393]: read /etc/ethers - 0 addresses
Wed Jul 31 11:53:30 2019 daemon.info dnsmasq[2393]: read /etc/hosts - 4 addresses
Wed Jul 31 11:53:30 2019 daemon.info dnsmasq[2393]: read /tmp/hosts/odhcpd - 3 addresses
Wed Jul 31 11:53:30 2019 daemon.info dnsmasq[2393]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Wed Jul 31 11:53:30 2019 daemon.info dnsmasq-dhcp[2393]: read /etc/ethers - 0 addresses
Wed Jul 31 11:53:32 2019 daemon.notice netifd: radio0 (11545): Could not find PHY for device 'radio0'
Wed Jul 31 11:53:32 2019 daemon.notice netifd: radio0 (11552): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 11:59:40 2019 daemon.info dnsmasq[2393]: read /etc/hosts - 4 addresses
Wed Jul 31 11:59:40 2019 daemon.info dnsmasq[2393]: read /tmp/hosts/odhcpd - 3 addresses
Wed Jul 31 11:59:40 2019 daemon.info dnsmasq[2393]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Wed Jul 31 11:59:40 2019 daemon.info dnsmasq-dhcp[2393]: read /etc/ethers - 0 addresses
Wed Jul 31 12:04:06 2019 daemon.notice netifd: radio0 (13730): Could not find PHY for device 'radio0'
Wed Jul 31 12:04:06 2019 daemon.notice netifd: radio0 (13745): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 12:10:54 2019 daemon.notice hostapd: wlan0: STA-OPMODE-SMPS-MODE-CHANGED 7c:2a:31:0b:e4:b5 static
Wed Jul 31 12:11:10 2019 daemon.notice hostapd: wlan0: STA-OPMODE-SMPS-MODE-CHANGED 7c:2a:31:0b:e4:b5 off
Wed Jul 31 12:18:11 2019 daemon.notice netifd: radio0 (17159): Could not find PHY for device 'radio0'
Wed Jul 31 12:18:11 2019 daemon.notice netifd: radio0 (17178): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 12:18:14 2019 daemon.notice hostapd: wlan0: STA-OPMODE-SMPS-MODE-CHANGED 7c:2a:31:0b:e4:b5 static
Wed Jul 31 12:18:24 2019 daemon.notice hostapd: wlan0: STA-OPMODE-SMPS-MODE-CHANGED 7c:2a:31:0b:e4:b5 off

I can connect to the routers Wi-Fi via Radio1 perfectly fine, but Radio0 is not showing up on scans.

Does anyone have any suggestions or pointers to help me out? I'm stumped at this point. Let me know if there's anything else you need from me and thanks in advance!

hwmode of the 5 GHz radio should be '11a' and set radio0 to channel within the 5 GHz band. Also add an option country to both radios with your 2 letter country code.

iw list, iw dev, and iwinfo wlan0 freqlist are useful for checking if the wifi driver is working.

1 Like

Thanks for the tips. I made the following changes:

Radio0:
channel switched to '36',
hwmode switched to '36a'
htmode switched to 'VHT80'
country 'AU' added to "config wifi-device" for both Radio0 and Radio1.

I'm still having the same issues though. I may have made some sort of silly mistake though, not entirely sure.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '36a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option disabled '0'
        option disable '0'
        option country 'AU'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt1'
        option encryption 'psk2'
        option key 'TestTest1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT40'
        option disabled '0'
        option disable '0'
        option country 'AU'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt2'
        option encryption 'psk2'
        option key 'TestTest1'

No it's '11a' as in 802.11a. The only possible hwmodes are 11g for a 2.4 GHz radio and 11a for a 5 GHz. Also remove both the 'disabled' and 'disable' lines.

Ah, my bad. Made that change though, and again, no luck. The same problem persists.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option disabled '0'
        option country 'AU'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt1'
        option encryption 'psk2'
        option key 'TestTest1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT40'
        option disabled '0'
        option country 'AU'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt2'
        option encryption 'psk2'
        option key 'TestTest1'

I would probably suggest to remove /etc/config/wireless and to generate a new one:

# rm -f /etc/config/wireless
# wifi config

Thanks for the tip. Just gave it a try and now I've not got a Radio0 (the 2.4 GHz radio) working fine, but no radio1. The plot thickens... Any ideas?

Could it be a driver issue? And if so, is there a package I can install to fix that? I'm reading a post mentioning kmod-MT7603 but can't find much info on whether it's a specific driver or a generic.

You might be missing the driver support (kmod-) package for your 5 GHz radio. mt7603e would be (exclusively) a 2.4 GHz radio, 5 GHz capable options would be mt7612 or mt7615 (going on a limb, I'd guess mt7615 as this driver didn't exist until very recently and therefore wasn't included in the devices shipping with it).

Probably should have checked, but I did already have mt7615e installed. So that doesn't seem to be the issue.

Actually, noticing something interesting. Under "dependencies", it's saying I'm missing iw-full for mt7615e. When I try to install it though, I get this error:

Collected errors:
 * check_data_file_clashes: Package iw-full wants to install file /usr/sbin/iw
	But that file is already provided by package  * iw
 * opkg_install_cmd: Cannot install package iw-full.

Does that mean anything that I don't understand?

Can you reboot and post full system log?

Here you go.

Wed Jul 31 17:23:12 2019 kern.notice kernel: [    0.000000] Linux version 4.14.132 (builder@buildhost) (gcc version 7.4.0 (OpenWrt GCC 7.4.0 r10574-273b803623)) #0 Wed Jul 24 18:36:27 2019
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Board has DDR2
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Analog PMU set to hw control
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Digital PMU set to hw control
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] SoC Type: MediaTek MT7620A ver:2 eco:4
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] bootconsole [early0] enabled
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] CPU0 revision is: 00019650 (MIPS 24KEc)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] MIPS: machine is D-Link DIR-510L
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Determined physical RAM map:
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000]  memory: 08000000 @ 00000000 (usable)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Initrd not found or empty - disabling initrd
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Zone ranges:
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Movable zone start for each node
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Early memory node ranges
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    0.000000] On node 0 totalpages: 32768
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    0.000000] free_area_init_node: node 0, pgdat 80523d10, node_mem_map 81000040
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    0.000000]   Normal zone: 288 pages used for memmap
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    0.000000]   Normal zone: 0 pages reserved
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    0.000000]   Normal zone: 32768 pages, LIFO batch:7
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    0.000000] random: get_random_bytes called from start_kernel+0x98/0x4a8 with crng_init=0
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    0.000000] pcpu-alloc: [0] 0
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    0.000000] Kernel command line: console=ttyS1,57600 rootfstype=squashfs,jffs2
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Writing ErrCtl register=0003dff0
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Readback ErrCtl register=0003dff0
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] Memory: 123004K/131072K available (4131K kernel code, 200K rwdata, 936K rodata, 1188K init, 220K bss, 8068K reserved, 0K cma-reserved)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] NR_IRQS: 256
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] CPU Clock: 580MHz
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] clocksource: systick: mask: 0xffff max_cycles: 0xffff, max_idle_ns: 583261500 ns
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] systick: enable autosleep mode
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] systick: running - mult: 214748, shift: 32
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.000010] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.015475] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.087720] pid_max: default: 32768 minimum: 301
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.097148] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.110171] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.130288] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.149777] futex hash table entries: 256 (order: -1, 3072 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.161989] pinctrl core: initialized pinctrl subsystem
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.173664] NET: Registered protocol family 16
Wed Jul 31 17:23:12 2019 kern.err kernel: [    0.717646] mt7620-pci 10140000.pcie: PCIE0 no card, disable it(RST&CLK)
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    0.730880] mt7620-pci: probe of 10140000.pcie failed with error -1
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.762492] rt2880_gpio 10000600.gpio: registering 24 gpios
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.773543] rt2880_gpio 10000600.gpio: registering 24 irq handlers
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.790026] clocksource: Switched to clocksource systick
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.801665] NET: Registered protocol family 2
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.811197] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.824981] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.837566] TCP: Hash tables configured (established 1024 bind 1024)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.850353] UDP hash table entries: 256 (order: 0, 4096 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.861873] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.874589] NET: Registered protocol family 1
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    0.883175] PCI: CLS 0 bytes, default 32
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.886179] rt-timer 10000100.timer: maximum frequency is 1220Hz
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    0.898954] Crashlog allocated RAM at address 0x3f00000
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.911240] workingset: timestamp_bits=14 max_order=15 bucket_order=1
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.930661] squashfs: version 4.0 (2009/01/31) Phillip Lougher
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.942167] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.975352] io scheduler noop registered
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.983061] io scheduler deadline registered (default)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    0.994092] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.009322] 10000500.uart: ttyS0 at MMIO 0x10000500 (irq = 13, base_baud = 2500000) is a Palmchip BK-3103
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.028948] 10000c00.uartlite: ttyS1 at MMIO 0x10000c00 (irq = 20, base_baud = 2500000) is a Palmchip BK-3103
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.048637] console [ttyS1] enabled
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.062397] bootconsole [early0] disabled
Wed Jul 31 17:23:12 2019 kern.err kernel: [    1.078924] cacheinfo: Failed to find cpu0 device node
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    1.089205] cacheinfo: Unable to detect cache hierarchy for CPU 0
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    1.109787] spi spi0.0: force spi mode3
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.118282] m25p80 spi0.0: mx25l12805d (16384 Kbytes)
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.128456] 4 fixed-partitions partitions found on MTD device spi0.0
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.141130] Creating 4 MTD partitions on "spi0.0":
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.150694] 0x000000000000-0x000000010000 : "jboot"
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.161383] 0x000000010000-0x000000210000 : "recovery"
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.172528] 0x000000210000-0x000000ff0000 : "firmware"
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.186065] 2 jimage-fw partitions found on MTD device firmware
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.197932] Creating 2 MTD partitions on "firmware":
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.207845] 0x000000000000-0x0000001ac97e : "kernel"
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.218640] 0x0000001ac97e-0x000000de0000 : "rootfs"
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.229401] mtd: device 4 (rootfs) set to be root filesystem
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.242429] 1 squashfs-split partitions found on MTD device rootfs
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.254822] 0x0000003c0000-0x000000de0000 : "rootfs_data"
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    1.266483] 0x000000ff0000-0x000001000000 : "config"
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.278073] libphy: Fixed MDIO Bus: probed
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.296538] gsw: setting port4 to ephy mode
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.304953] mtk_soc_eth 10100000.ethernet eth0 (uninitialized): port 0 link up (100Mbps/Full duplex)
Wed Jul 31 17:23:12 2019 kern.err kernel: [    1.323208] mtk_soc_eth 10100000.ethernet: generated random MAC address f6:9c:2a:ec:67:a4
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.339604] mtk_soc_eth 10100000.ethernet: loaded mt7620 driver
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.352067] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.369098] rt2880_wdt 10000120.watchdog: Initialized
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.380485] NET: Registered protocol family 10
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.393575] Segment Routing with IPv6
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.401060] NET: Registered protocol family 17
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.410013] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.435842] 8021q: 802.1Q VLAN Support v1.8
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.452402] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
Wed Jul 31 17:23:12 2019 kern.info kernel: [    1.473119] Freeing unused kernel memory: 1188K
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    1.482170] This architecture does not have kernel memory protection.
Wed Jul 31 17:23:12 2019 user.info kernel: [    2.356092] init: Console is alive
Wed Jul 31 17:23:12 2019 user.info kernel: [    2.363214] init: - watchdog -
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    2.760000] random: fast init done
Wed Jul 31 17:23:12 2019 user.info kernel: [    3.548860] kmodloader: loading kernel modules from /etc/modules-boot.d/*
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.697309] usbcore: registered new interface driver usbfs
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.708418] usbcore: registered new interface driver hub
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.719149] usbcore: registered new device driver usb
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.735506] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.750551] ehci-platform: EHCI generic platform driver
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.771339] phy phy-usbphy.0: remote usb device wakeup disabled
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.783154] phy phy-usbphy.0: UTMI 16bit 30MHz
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.792035] ehci-platform 101c0000.ehci: EHCI Host Controller
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.803532] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.819448] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.841600] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.855083] hub 1-0:1.0: USB hub found
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.863086] hub 1-0:1.0: 1 port detected
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.874388] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.888552] ohci-platform: OHCI generic platform driver
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.899322] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.912933] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.928845] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.966843] hub 2-0:1.0: USB hub found
Wed Jul 31 17:23:12 2019 kern.info kernel: [    3.974826] hub 2-0:1.0: 1 port detected
Wed Jul 31 17:23:12 2019 user.info kernel: [    3.987038] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
Wed Jul 31 17:23:12 2019 user.info kernel: [    4.005726] init: - preinit -
Wed Jul 31 17:23:12 2019 kern.info kernel: [    4.515590] usb 1-1: new high-speed USB device number 2 using ehci-platform
Wed Jul 31 17:23:12 2019 kern.info kernel: [    5.036501] hub 1-1:1.0: USB hub found
Wed Jul 31 17:23:12 2019 kern.info kernel: [    5.050252] hub 1-1:1.0: 4 ports detected
Wed Jul 31 17:23:12 2019 kern.info kernel: [    5.092120] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    5.135867] random: procd: uninitialized urandom read (4 bytes read)
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    6.512892] jffs2: notice: (419) jffs2_build_xattr_subsystem: complete building xattr subsystem, 4 of xdatum (3 unchecked, 1 orphan) and 45 of xref (1 dead, 0 orphan) found.
Wed Jul 31 17:23:12 2019 user.info kernel: [    6.547722] mount_root: switching to jffs2 overlay
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    6.589518] overlayfs: upper fs does not support tmpfile.
Wed Jul 31 17:23:12 2019 user.warn kernel: [    6.614267] urandom-seed: Seeding with /etc/urandom.seed
Wed Jul 31 17:23:12 2019 user.info kernel: [    6.752499] procd: - early -
Wed Jul 31 17:23:12 2019 user.info kernel: [    6.758350] procd: - watchdog -
Wed Jul 31 17:23:12 2019 user.info kernel: [    7.233552] procd: - watchdog -
Wed Jul 31 17:23:12 2019 user.info kernel: [    7.240214] procd: - ubus -
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    7.289389] random: ubusd: uninitialized urandom read (4 bytes read)
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    7.305567] random: ubusd: uninitialized urandom read (4 bytes read)
Wed Jul 31 17:23:12 2019 kern.notice kernel: [    7.319499] random: ubusd: uninitialized urandom read (4 bytes read)
Wed Jul 31 17:23:12 2019 user.info kernel: [    7.333399] procd: - init -
Wed Jul 31 17:23:12 2019 user.info kernel: [    8.255196] kmodloader: loading kernel modules from /etc/modules.d/*
Wed Jul 31 17:23:12 2019 user.err kernel: [    8.277019] urngd: jent-rng init failed, err: 2
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.293666] ip6_tables: (C) 2000-2006 Netfilter Core Team
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.316236] Loading modules backported from Linux version v5.2-rc7-0-g6fbc7275c7a9
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.331398] Backport generated by backports.git v5.2-rc7-1-0-g021a6ba1
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.348660] ip_tables: (C) 2000-2006 Netfilter Core Team
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.369423] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.452802] xt_time: kernel timezone is -0000
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.628347] PPP generic driver version 2.4.2
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.639985] NET: Registered protocol family 24
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.684242] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'soc_wmac.eeprom'.
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.706024] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 6352, rev 0500 detected
Wed Jul 31 17:23:12 2019 kern.info kernel: [    8.721553] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 7620 detected
Wed Jul 31 17:23:12 2019 kern.debug kernel: [    8.735984] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Wed Jul 31 17:23:12 2019 user.info kernel: [    8.754181] kmodloader: done loading kernel modules from /etc/modules.d/*
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: started, version 2.80 cachesize 150
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: DNS service limited to local subnets
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: using local addresses only for domain test
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: using local addresses only for domain onion
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: using local addresses only for domain localhost
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: using local addresses only for domain local
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: using local addresses only for domain invalid
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: using local addresses only for domain bind
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: using local addresses only for domain lan
Wed Jul 31 17:23:14 2019 daemon.warn dnsmasq[797]: no servers found in /tmp/resolv.conf.auto, will retry
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: read /etc/hosts - 4 addresses
Wed Jul 31 17:23:14 2019 daemon.info dnsmasq[797]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Wed Jul 31 17:23:14 2019 authpriv.info dropbear[830]: Not backgrounding
Wed Jul 31 17:23:16 2019 user.notice : Added device handler type: 8021ad
Wed Jul 31 17:23:16 2019 user.notice : Added device handler type: 8021q
Wed Jul 31 17:23:16 2019 user.notice : Added device handler type: macvlan
Wed Jul 31 17:23:16 2019 user.notice : Added device handler type: veth
Wed Jul 31 17:23:16 2019 user.notice : Added device handler type: bridge
Wed Jul 31 17:23:16 2019 user.notice : Added device handler type: Network device
Wed Jul 31 17:23:16 2019 user.notice : Added device handler type: tunnel
Wed Jul 31 17:23:18 2019 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/dhcp
Wed Jul 31 17:23:18 2019 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/radvd
Wed Jul 31 17:23:18 2019 user.notice ucitrack: Setting up /etc/config/wireless reload dependency on /etc/config/network
Wed Jul 31 17:23:19 2019 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/luci-splash
Wed Jul 31 17:23:19 2019 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/qos
Wed Jul 31 17:23:19 2019 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/miniupnpd
Wed Jul 31 17:23:19 2019 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/odhcpd
Wed Jul 31 17:23:19 2019 user.notice ucitrack: Setting up non-init /etc/config/fstab reload handler: /sbin/block mount
Wed Jul 31 17:23:20 2019 user.notice ucitrack: Setting up /etc/config/system reload trigger for non-procd /etc/init.d/led
Wed Jul 31 17:23:20 2019 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/luci_statistics
Wed Jul 31 17:23:20 2019 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/dhcp
Wed Jul 31 17:23:21 2019 kern.info kernel: [   19.027041] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Jul 31 17:23:21 2019 kern.info kernel: [   19.085888] device eth0 entered promiscuous mode
Wed Jul 31 17:23:21 2019 kern.info kernel: [   19.120893] br-lan: port 1(eth0.1) entered blocking state
Wed Jul 31 17:23:21 2019 kern.info kernel: [   19.131732] br-lan: port 1(eth0.1) entered disabled state
Wed Jul 31 17:23:21 2019 kern.info kernel: [   19.142895] device eth0.1 entered promiscuous mode
Wed Jul 31 17:23:21 2019 kern.info kernel: [   19.246708] br-lan: port 1(eth0.1) entered blocking state
Wed Jul 31 17:23:21 2019 kern.info kernel: [   19.257551] br-lan: port 1(eth0.1) entered forwarding state
Wed Jul 31 17:23:21 2019 kern.info kernel: [   19.268927] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Interface 'lan' is enabled
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Interface 'lan' is setting up now
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Interface 'lan' is now up
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: reading /tmp/resolv.conf.auto
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: using local addresses only for domain test
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: using local addresses only for domain onion
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: using local addresses only for domain localhost
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: using local addresses only for domain local
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: using local addresses only for domain invalid
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: using local addresses only for domain bind
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: using local addresses only for domain lan
Wed Jul 31 17:23:21 2019 daemon.info dnsmasq[797]: using nameserver 192.168.1.1#53
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Interface 'loopback' is enabled
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Interface 'loopback' is setting up now
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Interface 'loopback' is now up
Wed Jul 31 17:23:21 2019 daemon.notice netifd: bridge 'br-lan' link is up
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Interface 'lan' has link connectivity
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Network device 'eth0' link is up
Wed Jul 31 17:23:21 2019 daemon.notice netifd: VLAN 'eth0.1' link is up
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Network device 'lo' link is up
Wed Jul 31 17:23:21 2019 daemon.notice netifd: Interface 'loopback' has link connectivity
Wed Jul 31 17:23:22 2019 daemon.notice netifd: radio1 (1161): Could not find PHY for device 'radio1'
Wed Jul 31 17:23:22 2019 kern.info kernel: [   20.024367] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Wed Jul 31 17:23:22 2019 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Wed Jul 31 17:23:22 2019 daemon.err odhcpd[923]: Failed to send to ff02::1%lan@br-lan (Address not available)
Wed Jul 31 17:23:23 2019 daemon.notice netifd: radio1 (1201): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 17:23:23 2019 daemon.info procd: - init complete -
Wed Jul 31 17:25:20 2019 user.notice mac80211: Failed command: iw phy phy0 set antenna 0xffffffff 0xffffffff
Wed Jul 31 17:25:20 2019 daemon.notice netifd: radio0 (1160): command failed: Not supported (-122)
Wed Jul 31 17:25:20 2019 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Wed Jul 31 17:25:20 2019 daemon.notice netifd: radio0 (1160): sh: out of range
Wed Jul 31 17:25:20 2019 user.notice dnsmasq: found already running DHCP-server on interface 'br-lan' refusing to start, use 'option force 1' to override
Wed Jul 31 17:25:21 2019 daemon.info dnsmasq[797]: read /etc/hosts - 4 addresses
Wed Jul 31 17:25:21 2019 daemon.info dnsmasq[797]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Wed Jul 31 17:25:21 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Wed Jul 31 17:25:23 2019 kern.info kernel: [   23.514631] ieee80211 phy0: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration start
Wed Jul 31 17:25:23 2019 kern.info kernel: [   23.531210] ieee80211 phy0: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration end
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.373469] ieee80211 phy0: rt2800_loft_iq_calibration: Info - LOFT Calibration Done!
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.392882] ieee80211 phy0: rt2800_iq_search: Info - IQCalibration Start!
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.420804] ieee80211 phy0: rt2800_iq_search: Info - IQCalibration Done! CH = 0, (gain= d, phase= 0)
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.439942] ieee80211 phy0: rt2800_iq_search: Info - IQCalibration Start!
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.467398] ieee80211 phy0: rt2800_iq_search: Info - IQCalibration Done! CH = 1, (gain= 2, phase=3d)
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.485636] ieee80211 phy0: rt2800_loft_iq_calibration: Info - TX IQ Calibration Done!
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.516557] ieee80211 phy0: rt2800_rxiq_calibration: Info - RXIQ G_imb=-2, Ph_rx=0
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.541920] ieee80211 phy0: rt2800_rxiq_calibration: Info - RXIQ G_imb=4, Ph_rx=-2
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.566911] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.585241] br-lan: port 2(wlan0) entered blocking state
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.595995] br-lan: port 2(wlan0) entered disabled state
Wed Jul 31 17:25:24 2019 kern.info kernel: [   25.606969] device wlan0 entered promiscuous mode
Wed Jul 31 17:25:24 2019 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Jul 31 17:25:24 2019 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Wed Jul 31 17:25:25 2019 daemon.notice hostapd: handle_probe_req: send failed
Wed Jul 31 17:25:25 2019 daemon.notice hostapd: handle_probe_req: send failed
Wed Jul 31 17:25:26 2019 daemon.notice hostapd: 20/40 MHz operation not permitted on channel pri=11 sec=7 based on overlapping BSSes
Wed Jul 31 17:25:26 2019 daemon.err hostapd: Using interface wlan0 with hwaddr 78:54:2e:9d:4b:da and ssid "OpenWrt"
Wed Jul 31 17:25:26 2019 daemon.info dnsmasq[797]: read /etc/hosts - 4 addresses
Wed Jul 31 17:25:26 2019 daemon.info dnsmasq[797]: read /tmp/hosts/odhcpd - 0 addresses
Wed Jul 31 17:25:26 2019 daemon.info dnsmasq[797]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Wed Jul 31 17:25:26 2019 kern.info kernel: [   26.908199] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Wed Jul 31 17:25:26 2019 kern.info kernel: [   26.921124] br-lan: port 2(wlan0) entered blocking state
Wed Jul 31 17:25:26 2019 kern.info kernel: [   26.931761] br-lan: port 2(wlan0) entered forwarding state
Wed Jul 31 17:25:26 2019 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Wed Jul 31 17:25:26 2019 daemon.notice hostapd: wlan0: AP-ENABLED
Wed Jul 31 17:25:26 2019 daemon.notice netifd: Network device 'wlan0' link is up
Wed Jul 31 17:25:28 2019 daemon.info hostapd: wlan0: STA 7c:2a:31:0b:e4:b5 IEEE 802.11: authenticated
Wed Jul 31 17:25:28 2019 daemon.info hostapd: wlan0: STA 7c:2a:31:0b:e4:b5 IEEE 802.11: associated (aid 1)
Wed Jul 31 17:25:28 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 7c:2a:31:0b:e4:b5
Wed Jul 31 17:25:28 2019 daemon.info hostapd: wlan0: STA 7c:2a:31:0b:e4:b5 WPA: pairwise key handshake completed (RSN)
Wed Jul 31 17:25:32 2019 daemon.info dnsmasq[797]: read /etc/hosts - 4 addresses
Wed Jul 31 17:25:32 2019 daemon.info dnsmasq[797]: read /tmp/hosts/odhcpd - 1 addresses
Wed Jul 31 17:25:32 2019 daemon.info dnsmasq[797]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Wed Jul 31 17:25:35 2019 daemon.notice hostapd: wlan0: STA-OPMODE-SMPS-MODE-CHANGED 7c:2a:31:0b:e4:b5 off
Wed Jul 31 17:25:36 2019 daemon.info dnsmasq[797]: read /etc/hosts - 4 addresses
Wed Jul 31 17:25:36 2019 daemon.info dnsmasq[797]: read /tmp/hosts/odhcpd - 1 addresses
Wed Jul 31 17:25:36 2019 daemon.info dnsmasq[797]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Wed Jul 31 17:25:36 2019 daemon.info dnsmasq[797]: read /etc/hosts - 4 addresses
Wed Jul 31 17:25:36 2019 daemon.info dnsmasq[797]: read /tmp/hosts/odhcpd - 1 addresses
Wed Jul 31 17:25:36 2019 daemon.info dnsmasq[797]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Wed Jul 31 17:25:39 2019 daemon.err uhttpd[979]: luci: accepted login on /admin for root from 192.168.1.21
Wed Jul 31 17:25:55 2019 daemon.notice netifd: radio1 (1578): Could not find PHY for device 'radio1'
Wed Jul 31 17:25:55 2019 daemon.notice netifd: radio1 (1586): WARNING: Variable 'data' does not exist or is not an array/object
Wed Jul 31 17:26:02 2019 kern.notice kernel: [   45.972077] random: crng init done
Wed Jul 31 17:26:02 2019 kern.notice kernel: [   45.978864] random: 6 urandom warning(s) missed due to ratelimiting
Wed Jul 31 17:23:12 2019 kern.err kernel: [    0.717646] mt7620-pci 10140000.pcie: PCIE0 no card, disable it(RST&CLK)
Wed Jul 31 17:23:12 2019 kern.warn kernel: [    0.730880] mt7620-pci: probe of 10140000.pcie failed with error -1

This shows that there is no PCIE card detected. Does Wi-Fi work on stock firmware?
What is DIR-510L revision?

Actually, come to think of it, the 5GHz radio was dropping out occasionally on stock firmware last weekend. Maybe this is a hardware issue?
It's an A1 revision.

It looks like a hardware issue, like physical disconnect.

Bummer. Can't believe I didn't think about that. It was working 90% of the time though, the dropouts were only occasional and fixed themselves after a power cycle. Do you think I could I manually add radio1 into the wifi config file and just try power cycling it?

Jesus I'm an idiot. So, I power cycled the router rather than just rebooting and now radio1 is being detected and working fine. Just like I had to occasionally do on stock firmware. Don't know how long it will last, but it's at least something. Thanks for the help everyone!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.