Could not connect in SSH on ASUS RT-AC51U router to install OpenWrt

Bonjour, j'essaie d'installer la dernière version d'OpenWrt sur un routeur :ASUS RT-AC51U, en suivant le tutoriel https://openwrt.org/toh/asus/rt-ac51u, notamment par la méthode TFTP .
Tout se passe comme décrit dans le tutoriel jusqu’à l'étape de la convection en SSH/
J'obtiens le message: ssh: connect to host 192.168.1.1 port 22: Connection refused.
J'ai bien évidemment parcouru le net pour trouver une solution mais je n'en ai pas trouvée.
J'ai essayé de vérifier ou d'activer le SSH sur le routeur mais là non plus je ne sais pas comment faire.
Je précise que je suis sur système Linux et que je ne peu pas utiliser la méthode: ASUS Firmware Restoration Tool.
Est ce que vous savez si le routeur ASUS RT-AC51U peut se connecter en SSH ?
Où éventuellement m'indiquer une autre méthode pour flasher OpenWrt ?

Hello, I am trying to install the latest version of OpenWrt on a router:ASUS RT-AC51U, by following the tutorial: https://openwrt.org/toh/asus/rt-ac51u, in particular by the TFTP method.
Everything happens as described in the tutorial up to the SSH convection stage
I get the following message: ssh: connect to host 192.168.1.1 port 22: Connection refused.
Of course, I went online to find a solution, but I didn’t find one.
I tried to check or activate SSH on the router but I don’t know how to do that either.
I specify that I am on Linux system and that I can not use the method: ASUS Firmware Restoration Tool.
Do you know if the ASUS RT-AC51U router can connect in SSH?
Where can I find another way to flash OpenWrt?

The preferred language in the OpenWrt forum is english.
When writing in your native language, please always provide an english translation.
This way other users all around the world can take part in the discussion and possibly benefit from the outcome, without having to use a translator.

Thanks! :slight_smile:

Translation for hugues if someone can help.
Unfortunately I will not translate followups. Google Translate/chatgpt :grin:

Hello, Im trying to install the last version of Openwrt on an ASUS RT-AC51U while following the explanation @ https://openwrt.org/toh/asus/rt-ac51u, namely via TFTP.
Everything goes as explain up to the part of the SSH connection. I receive the message: ssh: connect to host 192.168.1.1 port 22: Connection refused.
Ive been since trying online sources for help. I dont know how to enable the SSH port on the router.
My main device from which I am doing all the config is a Linux OS and I cannot use the ASUS Firmware Restoration Tool.

Does anyone know if the ASUS RT-AC51U can be accessed by SSH?
Or any other mode of connection to flash Openwrt?

Are you certain that the OpenWrt has been flashed successfully?
Connection refused in ssh sounds like the router is not running anything on ssh port. Or the firewall is blocking it.

  1. Can you get IP from DHCP of OpenWrt on your PC?
  2. Are you connected on any other network at the same time which may conflict?
1 Like

when I put OpenWrt, with TFTP, on the router I got the answer that the move was done in 6.8 seconds.
I have authorized the move , for the port 22, on ufw ( which is the firewall on my computer).
And I also temporarily disabled the firewall on the router.
But when i try to connect to router in SSH , it the same result: ..... connection refused.
I'm not connected on any network when i try to connect to routeut in SSH
So when i try to use ifconfig i can't see the ip of OpenWrt.
Maybe this is the reason of the problem ?

So when i use nmap: nmap 192.168.1.1 -p 22
he answer is:

PORT STATE SERVICE
22/tcp closed ssh

I specify that I configured the ssh_config file with the connection allowed on port 22.
it seems to me that the problem of connection in SSH comes from the router
Also I looked on the router to check the SSH connection but I found nothing to enable the SSH connection or to indicate if this router can be connected in SSH.
I’m not a specialist at all and I still have a lot to learn
Also I will inquire about DHCP and if necessary I will install it on my pc

1 Like

DHCP is installed on all systems. It is the automatic way to get the settings from the router.
What is the output of ip addr; ip ro list table all; ip rule on your pc?