Correct way to mount NTFS partition to use with Samba Server


After installing latest snapshot of my router (TP-Link Archer C7 v4), I could not properly mount the NTFS partition, which I tried to accomplish configuring as the Samba Server mount before. The configuration was half complete, while the mount can be accessible via SCP, but not on Network anyway.
Which mount options shall be used especially?
General Settings
and Advanced Settings pages are here:
I'm using the older "block mount" package. Might this be an issue?
Also, here is the Samba Server configuration page:
I censored names on Hostname, Workgroup, Name and Allowed Users sections. Could you also give examples for these sections?


I wouldn't use NTFS as filessystem, use ext4 or some other filessytem out of the unix world

Is there no way to use it??

I would separate this into two issues: mounting the NTFS device and sharing it using SAMBA. Once you have it mounted (and it gets mounted if you can access it via SCP), then the underlying filesystem plays no role. So it looks like you have an issue with SAMBA.

Post your "/etc/config/samba" and "/etc/samba/smb.conf.template" files here, please.

I was accessing files via SCP, not anymore. Also, I could not upload new files in it, that time with previous firmware.
Here are the content of the files you requested:

config samba
	option homes '1'
	option name 'GURSU_OpenWRT'
	option description 'Samba Server'
	option workgroup 'GURSU'

config sambashare
	option browseable 'yes'
	option read_only 'no'
	option name 'Depo'
	option path '/mnt/sda1'
	option users 'Kerem Gürsu'
	option guest_ok 'yes'


	netbios name = |NAME| 
	display charset = |CHARSET|
	interfaces = |INTERFACES|
	server string = |DESCRIPTION|
	unix charset = |CHARSET|
	workgroup = |WORKGROUP|
	bind interfaces only = yes
	deadtime = 30
	enable core files = no
	invalid users = root
	local master = no
	map to guest = Bad User
	max protocol = SMB2
	min receivefile size = 16384
	null passwords = yes
	passdb backend = smbpasswd
	security = user
	smb passwd file = /etc/samba/smbpasswd
	use sendfile = yes


If you cannot access the data using SCP, then there is no point in trying to share it using SAMBA. You need to fix that first.

How did you configure the device? What is the contents of your "fstab" file? Does the device appear on "/dev"? ...?

Before upgrading the firmware, I could see the partition on \mnt\sda1, while connecting with SCP. Now, it's empty.
Here are the contents of the fstab file on /etc/config:

config global
	option anon_swap '0'
	option anon_mount '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '0'

config mount
	option target '/mnt/sda1'
	option enabled '1'
	option fstype 'ntfs'
	option enabled_fsck '1'
	option uuid '01C940F79654A800'
	option options 'rw,exec,auto,sync,relatime,dev,suid'

config mount
	option target '/mnt/sda2'
	option uuid '7a9e54d0-24a2-d401-4012-54d024a2d401'
	option enabled '1'
	option enabled_fsck '1'

config swap
	option device '/dev/sda3'
	option enabled '1'

By asking appearance on /dev, did you mean this?
If so, it is not there... How to correct this?

After upgrading the firmware, did you reinstall all needed packages?

I think I did. I had a list of installed packages and tried a reinstall of all of them.
What is the correct way to do that after upgrading base packages through upgrading with sysupgrade firmware?

As far as I know, the only way is exactly what you did... perhaps you missed a package?