Correct way to create a wan2 interface for mwan on ipq40xx switch

HI, what is the correct way to create a second wan interface on the zyxel 6617 router from one of the lan ports, to use mwan3? ma config now are default, eth0 lan interface and eth1 wan interface.
i never looked at the switch of this router, looks strange, i don't see in luci the wan port into the default vlan.

Check the example.
You'll need to create a new vlan, say 3, and assign one port untagged and CPU tagged.

1 Like

even if the default vlan have cpu untagged?

Yes, but don't change the default vlan1 (only remove the port)

1 Like

ok after the right vlan, how create in network a new wan2 interface? i dont understart the phisical setting.

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 1 5'

that's my config, is that ok for a second wan or i need another vlan?

ok i made it working, the problem was that the openwrt device page say that : Note that using eth0.2, eth0.1, won't work. but i my case when i set eth0.2 it work

Remove 5, keep only 0t 1

The example is trying to accomplish something different than you are.

1 Like

that right way

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '4 3 2 0'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 1 5'

config interface 'wanb'
	option ifname 'eth0.2'
	option proto 'dhcp'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.