Copy overlay filesystem to other board

Hi fellows,
I'm trying to copy the overlay filesystem from 1 board to another using SCP protocol. Because it will reduce installing python packages and linux apps for my board.
After transferring, the python package worked fine, but the it could not execute the app which is unzip.
It appeared in console:
bin/ash: unzip permission denied
Does anyone know how to fix this?
Thank you

That is not a supported procedure, you're messing up opkg's database, configfiles, target compatibility and file access rights/ security labels that way.

And take the scenic route from there, doing it properly, step by step.

Thank you for your advice.
I did this way because I have 1000 boards running python app. So I must reduce the time for installing and setting up. Do you have any suggestions for my case?

Auto DL and install the required content during 1st boot?

Hi frollic,

Could you explain how to do it?
Thank you

there are other threads about it, in the developers section.

some of the info might be obsolete, trial and error.

1 Like

Oh, I understood your point. But installation takes a very long time. I try to copy directly from board to board.

clone the whole storage, but then you might run into other issues, like incorrect MACs and unit specific settings.

Use SCP to copy just the relevant parts, not the whole overlay.

If you have 1000 boards, you should likely include the "permanent" parts like Python support directly into the firmware image, and use SCP to copy only the (small) app itself plus possible device-specific settings etc.

Note that you can include arbitrary files directly into the image both with the imagebuilder and the full toolchain. So, you might be able to include the files directly at the image.

1 Like

Linux version 3.18.21 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r47269) ) #5 Fri Nov 20 12:43:14 CET 2015
Python 2.7.9 (default, Oct 26 2015, 17:43:12) [GCC 4.8.3] on linux2 Type "help", "copyright", "credits" or "license" for more information.

This is my version of linux and python

wow, that's a lot of old versions in there

old kernel
old gcc
old python

Well, that is an unsupported version of OpenWrt and an already end-of-life Python, but that makes no diference here (assuming that you still can build firmwares for the device and are going to flash them in any case).

yes, the problem is: our firmware was built on very old version. So I think about tranferring all overlay filesystem from module to module approach.

Sadly. Developer team not support our product anymore

I tried to build customized image for my board and it appeared this error

Cloning into 'libubox-2015-11-08'...
fatal: unable to access '': server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
make[3]: *** [/home/tmc/openwrt/dl/libubox-2015-11-08-10429bccd0dc5d204635e110a7a8fae7b80d16cb.tar.gz] Error 128

I followed this git:

you could probably set it to skip the cert verification ...

Hi all, I have solved the problem, this is how I do:

  1. Download unzip package (.ipk) and copy to filesystem via SCP.
  2. opkg install unzip.ipk

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.