Coovachilli 1.4 in OpenWrt redirecting to instead of login page

Hi All,

I have installed Coovachilli1.4 in Openwrt image loaded Access point. All works fine in Android clients (Mobile, tablet etc) but not working as expected in Windows 10 pc.

When I am connecting from windows pc the browser comes up automatically (expected) with webpage which is not expected. When I surfed in google it says it is expected as per windows feature.

Is there any possibility to fix it from configuration or script side to make it work and it should open the captive portal login page first.

Vipin A

you probably have to make sure DNS calls on ipv4 and ipv6 are captured/redirected.

Could also try disabling ipv6 on the client.

1 Like

If Microsoft decided that their browser should show a specific page when it detects a captive portal, I do not think there is much you can do about it...

1 Like

@eduperez @frollic Thanks folks for the reply.

By the way I could resolve the problem. Actually if you have any other sort of internet connectivity then it will not redirect to portal page. I had an ethernet connection and when I removed it, worked correctly.

In that case, mark the thread as solved.

Sure, I don't see an option to close. Can you pls help me ?

I think it's in the buttons in your initial post.

(I never really post new topics, sorry)

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.