CooovaChilli not want work

Hello to all,
I'm new to the OpenWrt world.
I have a problem with coovachilli on an oolite MT7620 card.
Openwrt (provided by oolite) does not give problems, the coova-chiili package is installed regularly and starts without errors, create the device tun0, and connect to the remote Radius server.
My radius Server is a RADIUSdesk vm.
If I connect to chilli's hotspot, I enter regularly, but I can't access any site (time out), not even the splash page for login and the servers in the Walled Garden, either with ip address or dns.
It appears that the tun0 interface is cut off from the network.
I didn't find any guide on the subject, I tried a series of modifications with the interface Luci, on network, wireless and firewall but I didn't get any positive result.
All the documentation I found on coovachilli on OpenWRT does not talk about this problem, they teach how to install and customize coovachilli but do not talk about changes to be made to the OpenWRT network configuration
Someone could give me some ideas (or even better a step by step guide) how to solve the problem.
I am attaching the configuration files of my installation
Thanks a lot.

 etc config chilli --------------------------------------------------------
#
# Sample Coova-Chilli configuration file modified by gremaudpi
#
config chilli
 option disabled 1
 option interval 3600
 option swapoctets 1
 
 ######## TUN and DHCP Parameters ########
 option tundev 'tun0'
 option dhcpif 'wlan0'
 option net 192.168.182.0/24
 option lease 600
 option dns1 8.8.8.8
 option dns2 8.8.4.4
 option ipup '/etc/chilli/up.sh'
 option ipdown '/etc/chilli/down.sh'
 
 ######## Radius parameters ########
 option radiusserver1 '192.168.178.210'
 option radiusserver2 ''
 option radiusauthport 1812
 option radiussecret 'testing123'
 option radiusnasid 'nas01'
 #option ssid 'ACME-company'
 
 ######## Universal access method (UAM) parameters ########
 option uamlisten 192.168.182.1
 option uamserver 'http://192.168.178.210/cake3/rd_cake/dynamic-details/chilli-browser-detect/'
 option uamsecret 'greatsecret'
 option uamallowed ''
 option uamdomain ''
 option uamanydns 1
 option uamaliasname 'login'
 option nouamsuccess 1 

 etc config network --------------------------------------------------------

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd67:e663:d07b::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.178.1'
	option dns '192.168.178.1'
	option ipaddr '192.168.178.202'
	option ifname 'eth0 eth0.1'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '0c:ef:af:c4:f2:26'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4 5 6t'

config route
	option interface 'lan'
	option target '224.0.0.0'
	option netmask '224.0.0.0'
	option type 'multicast'

 etc config firewall --------------------------------------------------------

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user

 etc config wireless --------------------------------------------------------

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid '7620FW-F226'
	option encryption 'none'
	option network 'lan'

Although having several different hotspot systems running on openwrt plus chilli, your config is too complicated to be checked without serious testing.
However, I strongly suggest, you first bring your setup to work on real linux, i.e. ubuntu.
Then port to openwrt, but without firewall first, because there I suspect to be the problem, as coova-chilli meddles around with iptables. And might conflict with your custom rules.

option disabled 1 at the top of the file?
You need to attach tun0 to something. After a chilli user is authorized, chilli will start passing his packets from wlan to tun for Internet access. Chilli processes every packet from the public users' interface (wlan) in userspace (*) then throws it into the tunnel if it deserves to go to the Internet. So your tunnel should bridge to some sort of guest network that forwards to wan.
The up.sh script is often part of this process.

Reloading the third party firmware which works and examining its configuration may be helpful. Chilli is quite complicated.

(*) This is often a burden on devices with a small CPU.

Thanks for your answer,
I will try to create a test installation on Ubuntu, once find the correct parameters, in fact increase the chances of OpenWrt success.

Thank mk24 for pointing out "option disabled 1" in config / chilli, it's an oversight but it shows that something is wrong with the chilli configuration files.

I have already tried to associate tun0 with br-lan but I get this error:

Wed Jul  3 18:39:38 2019 local6.err coova-chilli[1527]: tun.c: 1100: 5 (I/O error) tun_write(60) = -1
Wed Jul  3 18:39:39 2019 local6.err coova-chilli[1527]: safe.c: 88: 5 (I/O error) write(4, 62)
Wed Jul  3 18:39:39 2019 local6.err coova-chilli[1527]: tun.c: 1100: 5 (I/O error) tun_write(62) = -1
Wed Jul  3 18:39:39 2019 local6.err coova-chilli[1527]: safe.c: 88: 5 (I/O error) write(4, 65)
Wed Jul  3 18:39:39 2019 local6.err coova-chilli[1527]: tun.c: 1100: 5 (I/O error) tun_write(65) = -1
Wed Jul  3 18:39:39 2019 local6.err coova-chilli[1527]: safe.c: 88: 5 (I/O error) write(4, 68)

Proper config of chilli is not a trivial task. You might start with a simpler (basic) configuration first. BTW: coova-chilli was not officially supported for ipv6.