Converting GL.iNet MT3000 (Beryl AX) from CN to Global

i followed update the firmware using the uboot and followed every step.
it says update successful, and restarting.

but my GL-MT3000 stuck. it keeps rebooting and rebooting.

please help

@redangelz - are you using the official OpenWrt (downloaded from openwrt.org)?

I dont think i have. I tried update the firmware via uBoot (debrick) method. Using official firmware. But still no success.

Then i found this forum. When i browse here, the openwrt file is .bin

While the firmware usually .img

Hence i dont know where and how to upload the .bin file.

i'm stuck at this step. i can't even load the firmware to the router.

it says successful and restarting. but now it stuck on restart process (restart death loop)

I heard from my friend who bought the China version that flashing official OpenWrt on Beryl AX doesn't require any change to the uboot, so the uboot "CN" country setting only affects GL's firmware behavior, using official OpenWrt it will not have any issue (so now I am also waiting for my Beryl AX to come from China after Chinese New Year)

Ok never mind guys. i successfully restore it and it works flawlessly.
Thank youuuuuuuu so much

GL-MT3000

echo "US" |dd of=/dev/mtdblock3 bs=1 seek=136
sync
reboot

this works perfectly