Constantly losing connection to all Google services and Playstation Store (PS4)

I have D-Link DIR-320NRU with latest LEDE, default config, no tampering, only installed UPnP.
All devices work fine (wired or Wi-Fi), except Android tablets and PS4.

Tablets randomly lose connection to all Google services - no search auto-suggestions in browser, Google Play not loading content, Play Games not logging-in e.t.c.
Every other connection are not affected, all non-Google pages are loaded instantly.
Some time after Google connections are reestablished (it can take 10-20 seconds).

Almost same situation with PS4.
Always, with no exceptions, after several minutes after logging in it loses connection to Sony servers - store not loading, news feed and game info at main screen are not loading.
Internet connection and multiplayer are not affected - I can browse web and play online.
In case with PS4, connection to Sony servers (I think, they are content servers) will not be restored automatically, and only solution - relogin to have some time to be able to browse store.

I tried to connect to a neighbor router DIR-300NRU6 with stock firmware (they are couple of walls away and I don't think that they have different provider, here is only one reliable provider available) - everything works perfect, not a single disconnect.
Tried to change my DNS, tried to disable IPv6 - no effect.
LEDE logs have no errors.

What's happening, where to look, what to do?
There was no such problem some time ago (maybe a year or two ago, when I still used old OpenWrt).

For PS4 use a static IP, give it a static lease under 'DHCP and DNS' in LUCI. Don't rely on UPnP. Forward the appropriate ports to the static IP of the PS4 under 'Firewall':

TCP: 80, 443,1935, 3478-3480, 10070-10080
UDP: 3478-3479, 3658

Check for specific games you play as well. For instance I know Destiny 2 runs a lot smoother with less network error codes if you also have UDP 3074 forwarded as well.

If that does not work use a ethernet cable or check your Wi-Fi Signal at the location of your PS4.

Tried static IP and no UPnP some time ago - no changes, still disconnects (I think, this is Sony's store and/or content/info servers) after couple of minutes after login with either cable or Wi-Fi.

Earlier I thought that was some sort of ISP issue or PS4 firmware bug and ignored this problem.
But recently purchased tablet shows same symptoms with Google servers and then I tried old tablet, and it shows same problem (I did not noticed that earlied, because old tabet was not used online actively).

The fact, that this problem was not present in old OpenWrt (too bad I did not noticed that moment, when this problem occured) and everything still works with non-LEDE firmware, is an indicator, that something affects connections at least for me (maybe this is some rare case for combination of this router model and LEDE).

Did you check logread and dmesg for clues? Do you run SQM, QoS or other optional packages?

Only one additional package installed: luci-app-upnp
System and kernel logs show nothing suspicious.
As for logread and dmseg: I don't even know what is that, and need some help - I think, my skills are a little higher than the average user (I can access file system and use command line, but prefer LuCi, of course) and with some explanation I can look deeper, just say what to do.

Keep UPnP enabled, keep a static IP on your PS4, and forward those ports as well. My UPnP redirects are not cleared until I manually do it or until the router is rebooted. If your PS4 is assigned a different IP from DHCP and the redirects are still there it could cause issues. There are some ports they don't recommend to forward such as UDP 9305-9308 that the PS4 uses. I do not have those ports forwarded but I know that UDP 9308 is always requested by PS4 whenever I'm connected to PSN. UDP 9307 is used by PS4 Parties as well. Let UPnP handle those. And just making sure, but after installing 'luci-app-upnp' did you go to Services->UPnP and check the box labelled 'Start UPnP and NAT-PMP service'?

Sony's servers have been having issues of the past couple days to be fair. Hopefully, they get it sorted soon. But it's mostly laggy, but still working. Not sure about Google. It could be your router with LEDE though. My router with LEDE works absolutely fine for PSN and my android phone.

My ISP uses IPv4 currently. I've had no problems with IPv6 enabled or disabled on both the WAN and LAN connecting to PSN or google services on my phone. I've had IPv6 disabled before, I currently have it enabled since their provisioning mode is APM in case they change over in the near future.

You said you tried different DNS servers as well? I leave my router with default DNS servers from DHCP from my ISP. I use a combination of Google, Level 3, and NTT DNS servers on my PS4 network settings depending on what my speeds results are from a test when I sign on. I've found about 4 stable DNS servers that work well for me. They are: - Google - Level 3 - NTT - NTT

Hope you can get it sorted. I know one of my friends actually experienced problems with PSN similar to yours. It turns out their modem was going bad (they have a separate TP-Link Archer C8 router). Their modem eventually died and after they replaced it they were amazed how fast friend's list and the store loaded. LEDE should not be an issue. But there's always a possibility for bugs on certain devices.