Constant wireless disconnects due to excessive missing ACKs

Hello.
I have D-Link DIR-320 B1, currently with Lede 17.01.4 (basically, default config).
Had no problems in years with 7 of my wireless devices (consoles, phones and tablets) in same room - everything works perfect.

But my new Android 6 tablet (Lenovo Tab 3 8 Plus) keeps losing network.
It can happen randomly - for example, I can notice that every 3 minutes in Google PlayStore, or only couple times per hour (maybe it happens more often, but I'm not checking something online that time).
And it seems, tablet doesn't even notice that there is no network - signal strenght icon is there (filled icon - "connected"), but data is not transfered (no send/receive arrows).
If there was a download, then it stops and not trying to resume or restore connection.
Or, for example, Google PlayStore doesn't say "wifi is off" - it just keeps trying to load page (rotating loading symbol).
Some time after it gets his connection back, or it much faster just to turn off/on wireless.

Router system log have this message: "disconnected due to excessive missing ACKs".
I tried to add "disassoc_low_ack 0" and this error gone from log, but this not solved connection problem.
I tried to use another router DIR-300NRU6 with stock firmware - everything OK, not a single disconnect.
Hope for your help.

must be something with the hostapd, you could try restarting it see if that helps, which hostapd are you using? mini common or hostapd?