Connection problems with D-Link DIR-842

Hi, I have a snapshot version running on my DIR-842 and while it seems to work correctly, I have the following problem with it:

  1. I can get to the internet through it when using NetworkManager (linux), but then the device can not be found (not pingable, not found from its address).

  2. I can get to the device when using Systemd-networkd (linux), but then I can not connect to the internet.

Because of this, I decided to configure systemd-networkd to provide connection and disable NetworkManager completely. However, the problem did not get solved and so now the device can not be found at all, but network connection is still fine.

Here's my system structure:

I have two machines connected with wire to the DIR-842 -router (192.168.1.1) and one wire connection from there to my ISP -router (192.168.8.1). ISP -router's connection to the internet is wireless.

I'm pretty sure the problem is in connection settings, but what should I put there to get this working? I just can't figure out. The another machine (server) just can't find the router at all, but the internet connection works well.
My skill level with these things is maybe somewhere between newbie to amateur, depending from the task at hand.

is everything connected via the DIR-842, or are some devices connected to the ISPs router ?

if you don't need the two subnets, you should really configure your DIR as an AP.

I would like to have it working like an additional firewall and SSH server. After getting these things to work, I'm willing to try it as a VPN server. If possible it would be nice to have a VPN -tunnel inside SSH -tunnel, but maybe that can't be done(?) So I guess AP isn't enough. Everything is connected to DIR-842.

and how are the ISPs router and the DIR interconnected?

With wire, from lan port to lan port. The ISP router has one combined lan/wan port, but I'm not using it. I tried it once but it didn't fix anything.

That's probably why you are having issues.

Use WAN port on the DIR.

Connecting LAN-LAN bypasses the so important firewall in the DIR completely :slight_smile: