Connecting to same network twice

Hello, I live in a hotel which gives a connection of 25 mbps per device. I want to connect my router with 2 ethernet connections and set up load balancing. However I am unable to get an ip from from both ports at the same time. I get an IP from either connection, which tells me that the router detects that it is the same device. How can I get around this? I have tried changing the mac address but it still doesnt work.

How many ports are available in the hotel room?
Show us the configuration you tried and didn't work.
ubus call system board; uci export network

there are two access points with 4 ethernet ports each, so technically 8, but for now I am just trying to get two of them balanced. heres the config. I tried connecting to the wifi with my phone and used usb tethering and it worked. So, its definitely due to the main router not giving it an IP. In the internet interfaces setting, if I disable either connection, the other one promptly connects.

{
        "kernel": "5.10.161",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "TP-Link Archer C6 v3",
        "board_name": "tplink,archer-c6-v3",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.3",
                "revision": "r20028-43d71ad93e",
                "target": "ramips/mt7621",
                "description": "OpenWrt 22.03.3 r20028-43d71ad93e"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd84:1447:ade6::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option hostname '*'

config device
        option name 'lan1'
        option macaddr '28:EE:52:B8:98:CB'

config interface 'wanb'
        option device 'lan1'
        option proto 'dhcp'

One thing is to use a different hostname in wanb interface.
Then verify with tcpdump that the egress packets are using the correct MAC addresses per interface.
tcpdump -i wan -evn and tcpdump -i lan1 -evn

1 Like

unfortunately that didn't work either. it simply doesn't even obtain an IP.

What is the tcpdump output?

1 Like

this is for wan

tcpdump: listening on wan, link-type EN10MB (Ethernet), capture size 262144 bytes
16:51:21.327646 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.4.121 tell 10.150.0.1, length 46
16:51:21.430458 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.2.112 tell 10.150.0.1, length 46
16:51:21.515540 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.2.210 tell 10.150.0.1, length 46
16:51:21.573749 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.1.162 tell 10.150.0.1, length 46
16:51:21.843554 d6:22:fa:ba:d0:b3 > 33:33:00:00:00:02, ethertype IPv6 (0x86dd), length 70: (hlim 255, next-header ICMPv6 (58) payload length: 16) fe80::d422:faff:feba:d0b3 > ff02::2: [icmp6 sum ok] ICMP6, router solicitation, length 16
          source link-address option (1), length 8 (1): d6:22:fa:ba:d0:b3
16:51:22.009427 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.1.120 tell 10.150.0.1, length 46
16:51:22.072296 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.7.68 tell 10.150.0.1, length 46
16:51:22.166741 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.3.156 tell 10.150.0.1, length 46
16:51:22.308406 92:7b:40:da:e4:01 > 01:00:5e:00:00:fb, ethertype IPv4 (0x0800), length 171: (tos 0x0, ttl 255, id 19461, offset 0, flags [none], proto UDP (17), length 157)
    10.150.4.208.5353 > 224.0.0.251.5353: 0 [4q] [1au] PTR (QM)? lb._dns-sd._udp.local. PTR (QM)? _companion-link._tcp.local. PTR (QM)? _homekit._tcp.local. PTR (QM)? _sleep-proxy._udp.local. (129)
16:51:22.443613 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.2.112 tell 10.150.0.1, length 46
16:51:22.474849 a2:b9:2b:3a:38:d0 > 01:00:5e:00:00:fb, ethertype IPv4 (0x0800), length 136: (tos 0x0, ttl 255, id 24804, offset 0, flags [DF], proto UDP (17), length 122)
    10.150.3.146.5353 > 224.0.0.251.5353: 8 [2q] PTR (QM)? _%9E5E7C8F47989526C9BCD95D24084F6F0B27C5ED._sub._googlecast._tcp.local. PTR (QM)? _googlecast._tcp.local. (94)
16:51:22.539531 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.2.210 tell 10.150.0.1, length 46
16:51:22.603514 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.1.162 tell 10.150.0.1, length 46
16:51:23.006579 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.4.121 tell 10.150.0.1, length 46
16:51:23.023505 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.1.120 tell 10.150.0.1, length 46
16:51:23.083656 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.7.68 tell 10.150.0.1, length 46
16:51:23.179497 d4:f5:ef:81:3f:c1 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Request who-has 10.150.3.156 tell 10.150.0.1, length 46
^C

and this is for lan1
tcpdump: lan1: That device is not up

however if i stop wan and use lan1 instead, the outputs are reversed

I forgot to mention, my router uses captive portals to log in. So, I spoof the mac address of the router on my laptop and connect it and it works. However it still doesnt work when I try to change the mac address of the second lan.

To capture DHCP related traffic, you need to trigger the DHCP client while tcpdump is running:
https://openwrt.org/docs/guide-user/network/protocol.dhcp#troubleshooting

3 Likes

And the mac address is the same or it changes?

1 Like