Connecting to router/modem in bridge mode

Dear,
I have an ADSL tplink router/modem that I configured in bridge mode, and I downloaded openwrt on a raspberry pi to use it as the main router and use the tplink router as a dumb modem but I am not able to connect to the internet
it gives me "Timeout waiting for PADO packets"
/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb5:d991:9398::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'WAN'
        option proto 'pppoe'
        option password '--------'
        option ipv6 'auto'
        option username '---------------'
        option device 'eth0.2'
        option mtu '1480'

config device
        option name 'eth0.2'
        option type '8021q'
        option ifname 'eth0'
        option vid '2'

Have you verified the TPlink bridge modem is functioning correctly by connecting a known working 'router' using PPPoE ?

Does your ADSL ISP use PPPoE protocol?
Some ISPs only use PPPoA.

I do not have another known working 'router', but I Know that my ISP uses PPPoE protocol because before installing openwrt I was using my tplink router/modem as main router and it was using PPPoE

Is there another way I can make sure that the TPlink bridge modem is working correctly?

fwiw, if you have a Windows PC with ethernet socket, you could perhaps test the bridge modem

https://www.tp-link.com/uk/support/faq/921/

1 Like

The configuration posted is going to emit and expect pppoe packets with a VLAN tag of 2. Is this how the modem is configured?

Set up a wifi AP for lan, then you can dedicate eth0 with no tag to be wan-- removing eth0 from lan. For any serious use you'd want to add a USB-Ethernet adapter so you have dedicated Ethernet ports for both wan and lan.

I tested it with my pc and I accessed the internet successfully so it seems that it is a problem with my openwrt config, what should I do?

Sorry I am quite new to openwrt, please elaborate on how to "Set up a wifi AP for lan"

Did you have to set up a pppoe tunnel on the pc to make it work? If not, then you should set the wan protocol to dhcp. Not all DSL providers require pppoe.

Also, why do you have the mtu set to 1480? Where did that number come from?

yes I did set up a pppoe tunnel on the pc, I was just experimenting with different mtu

I succeeded in making the router connect to the internet here is the config

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb5:d991:9398::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'wlan0'

config interface 'WAN'
        option proto 'pppoe'
        option password '------'
        option ipv6 'auto'
        option username '------------'
        option device 'eth0'
        option mtu '1500'

now when i diagnose openwrt router it has internet but my pc does not

Ok in that case the mtu should be set to 1492. Setting it to 1500 will cause path mtu difficulties like blackhole tcp connections because you can't do 1500. You lose 8 bytes of mtu to the pppoe header and must therefore be limited to 1492.

eth0 can't work as both wan and lan. That's why I said to use wifi for lan, or buy a USB converter to be a second Ethernet port.

To use wifi for lan add your country code on the wifi-device remove the disabled line. This will start an unencrypted AP. You probably want to under the wifi-iface add:

   option encryption 'psk2'
   option key 'set your secret key'