Connecting Starlink (Bypass mode)

Hello

Still struggling with making 2 interfaces working together, most notably to allow my LAN to use the Starlink connection.

  • Eth1 is connected to the Ethernet box of Starlink, etho and wifi in under on bridge (br-lan) at 192.168.1.61

  • Eth1 gets properly an IP from Starlink (100.xxx.xxx.xxx)

  • On the device (openwrt) connected to the Starlink ethernet box, I can ping both the world and the LAN.

-> If I connect to the device by eth0 or Wifi, specifying 192.168.1.61 as default gateway, I can't ping the world.

What is wrong ?

Thank you

Config is now as follows

/etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        option stp '1'
        option igmp_snooping '1'
        option ipv6 '0'
        option bridge_empty '1'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.61'
        option netmask '255.255.0.0'
        list dns_search 'maduao.net'
        option delegate '0'
        option defaultroute '0'

config interface 'STARLINK'
        option proto 'dhcp'
        option device 'eth1'
        option delegate '0'

config interface 'RELAY'
        option proto 'relay'
        list network 'lan'
        list network 'STARLINK'
        option forward_dhcp '0'
        option delegate '0'





/etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option distance '1500'
        option cell_density '0'
        option channel '11'
        option country 'US'
        option txpower '30'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'HOME'
        option key 'XXX'
        option encryption 'psk'




/etc/config/firewall 

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'LAN'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

At this point you'd be better off resetting the OpenWRT device to default and starting from scratch. The default config should (although without knowing what the device is it's impossible to be 100%) assign one Ethernet port as a WAN DHCP client and the other as a static LAN interface, with all the necessary configs to allow routing. You can then give the LAN interface whatever IP address you want and set up the WiFi linked to the LAN network.

3 Likes

No, this does not work

People keep insisting that "it shall work" but it does not

The 2 interfaces (eth1 and eth0) seems not willing to talk to each other

I also changed the hardware, reset to newest openwrt, etc...

Problem keeps the same : one ETH interface does /not/ communicate with the other

Which is extremely likely to be due to changes you have made to the config. Hence resetting to defaults.

You won’t get any better advice than what @krazeh posted.

ByPass is just that. The Starlink router just provides power to your dishy in bypass mode. There should be virtually no network changes needed when you connect the Starlink Ethernet dongle to your router wan port from your previous providers network.

1 Like

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

Read above, already did

Are you saying that still remains as your default config from a reset?

1 Like

No, not saying that. Why ?

Is there anyone to understand at least the problem, even if not having already the solution ?

Making 2 ETH talking to each other on the same device shall not be such a big deal, right ?

We all understand the problem. And we're trying to assist you with the solution. The issue is your refusal to assist yourself.

It's not. That's what OpenWRT does by default. The fact it's not working for you is (to repeat myself) extremely likely to be down to changes you have made to the config. Now we could either try working backwards through those changes to find which one (or combination) is the issue, or you could take our advice and reset the OpenWRT device to it's default settings.

2 Likes

Not really planning to do test and learn, and "ah it works, I don't understand why, but it works somehow"

I just need to know how to make eth0 speak with eth1

There, answered.

2 Likes

This forum is really hard to communicate with.

Why is it so hard to clarify how to make 2 interfaces speak to each other in one openwrt device ?

It's not. You've had the answer several times in this thread. Your refusal to make the necessary changes are not an issue with the forum...

1 Like

I am NOT asking for changes or whatever reset.

I am asking for explanation on how to make 2 ethernets speak to each other

Why this question is so hard ?

Because without working back through all the changes you have made to the default configs it's very difficult to pinpoint what you've broken. In all situations you are going to have to make changes to your configs to make it work. Now you can either do it bit by bit till we find the issue(s), or you can do the sensible option and start from scratch (which is OpenWRT doing exactly what you want).

1 Like

This is an under defined question... put both into one bridge, et voila they will "talk" to each other on L2. However as little as I understand starlink bypass mode from a quick read, you likely need to attach your own NAT router (which operates on L3) so you can attach more than a single device...
That, router as L3 gateway, is the default mode for OpenWrt, hence the recommendation to revert to the default configuration and connect the starlink ethernet cable to the WAN interface...

Sidenote: in such situations it might be the description of the problem that might simply not be as clear as intended...

We tend to be a quite friendly and welcome bunch with a wide array of individual expertise, all in all this is IMHO one of the nicer places within the internet. However, we do operate on some unspoken premises and trying to work "against the grain" is not necessarily a great experience (as you discovered).
Then again, it takes two to tango and to communicate.

Well it is not, just create a bridge including both and you are done, however that in all likelihood will only work if starlink is willing to supply more than one IPv4 address via its DHCP servers (which they might or might not do).

Because you seem to operate on the premise that this forum's function is to supply direct answers to your questions that also happen to guess what you actually intend to do...

Well, either bridge them for L2 connectivity or route between them for L3 connectivity. Now, what do you actually want to achieve here? Do you want to replace the starlink router with your own router? If yes, what kind of services do you want to operate on that router?

EDIT:
https://starlinkinsider.com/starlink-bypass-mode/ writes:

Additionally, the NAT functionality of the Starlink router will also be lost, which allows multiple devices to share a single public IP address.

Although you’re technically able to replace the DHCP services with a switch, it won’t be sufficient unless you can configure the switch to do NAT/masquerade.

Without this configuration, you won’t have anything in place to share the single CGNAT (Carrier-grade NAT) IP address from Starlink.

making me think you really need a pretty run-of-the-mill router configuration (standard NAT firewalling router with internal DHCP services) which as far as I can tell default OpenWrt will offer with a few configuration steps.

3 Likes

Look, you dont even answer anyting related to my question

I have a device, 2 ethernets and 2 IPs. When I ssh to the device, I can 2 both IP and related subnet

When I am on a PC connect to one of the ETH, I can not see the other, even with a gateway pointing to the device.

I tried the "starlink" example to put the example to life, but even so, I get only "reset your device" answers

I don't care about the actual device, I need to UNDERSTAND how to make those 2 ethernets talk to each other

They do not!

1 Like

citation needed, no idea whom you are addressing as "you" here, let alone which post; context does matter...

The "reset" recommendation is IMHO shorthand for try the default configuration, if it works you can go wild in figuring out what exactly each parts of that configuration deliver...

However to give you a starting point:
L3 routing: https://openwrt.org/docs/guide-user/network/routing/basics

4 Likes