Connect to Wireguard Server via Mullvad Port Forwarding

I have an unexpected issue with Wireguard. Please see description below.

Existing Network:
-I have a wireguard interface which connects to Mullvad VPN that acts as a secondary WAN for a Guest VLAN. This is 100% separate from my primary LAN (with regular WAN) with no issues.

Note: Mullvad allows port forwarding so users can privately host services on their public IP.

Plan:
I want to host a WG server on my GUEST VLAN (192.168.100.0) through such a forwarded port.

How it is going:
-I can connect successfully to the GUEST VLAN WG peer hrough the forwarded port on the Mullvad public IP. Handshake occurs and I am inside tunnel 192.168.9.0.

The strange part....my client specifies the Mullvad IP, but upon connecting, instantly it shows "endpoint IP" as my regular WAN/ISP IP.

Has anybody seen this before or know where to begin as a troubleshoot?

/etc/config/network

Summary
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.40'
	option force_link '0'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 'auto'
	option peerdns '0'
	list dns 'XXX.XXX.XXX.XXX'
	option ifname 'eth1.20'
	option password 'XXXXXXXXX'
	option username 'XXXXXXXXXXXX@XXXXXXXXX'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1000'
	option ports '3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '20'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '40'
	option ports '0 1 2 5t'

config interface 'WGINTERFACE'
	option proto 'wireguard'
	option private_key 'XXXXXXX'
	list addresses 'XXX.XXX.XXX.XXX/32'

config wireguard_WGINTERFACE
	option public_key 'XXXXXXXXXXXXXXX'
	option description 'XXXXXXXXX'
	option endpoint_host 'XXX.XXX.XXX.XXX'
	option endpoint_port '51820'
	list allowed_ips '0.0.0.0/0'

config interface 'GUEST_LAN'
	option proto 'static'
	option type 'bridge'
	option netmask '255.255.255.0'
	option ifname 'eth0.1000'
	option ipaddr '192.168.100.1'

config interface 'vpn'
	option proto 'wireguard'
	option private_key 'XXXXXXXXXX'
	option listen_port '51820'
	list addresses '192.168.9.1/24'

config wireguard_vpn 'wgclient'
	option description 'Admin'
	option public_key 'XXXXXXXXXXXXXXXXXX'
	list allowed_ips '192.168.9.2/32'

/etc/config/firewall

Summary

config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'

config zone 'lan'
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone 'wan'
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
option enabled '0'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config zone
option name 'GUEST_LAN'
option output 'ACCEPT'
option input 'REJECT'
option forward 'REJECT'
option network 'GUEST_LAN vpn'

config zone
option mtu_fix '1'
option input 'REJECT'
option forward 'REJECT'
option masq '1'
option output 'ACCEPT'
option name 'WGINTERFACE'
option network 'WGINTERFACE'

config rule
option src_port '68'
option src 'GUEST_LAN'
option name 'Allow-Guest-DHCPv4-Input'
option family 'ipv4'
option target 'ACCEPT'
option dest_port '67'
list proto 'udp'

config forwarding
option dest 'WGINTERFACE'
option src 'GUEST_LAN'

config redirect
option dest_port '22'
option src 'lan'
option name 'SSH to rpi'
option target 'DNAT'
option dest_ip '192.168.100.100'
option dest 'GUEST_LAN'
list proto 'tcp'
option src_dport '4000'

config redirect
option dest_port '51820'
option src 'WGINTERFACE'
option name 'Mullvad Admin In'
option src_dport '54861'
option target 'DNAT'
option dest 'GUEST_LAN'
list proto 'udp'
option dest_ip '192.168.9.1'

config rule
option dest 'GUEST_LAN'
option src 'WGINTERFACE'
option name 'Admin_In'
option target 'ACCEPT'

config rule 'wg'
option name 'Allow-WireGuard'
option src 'wan'
option dest_port '51820'
option proto 'udp'
option target 'ACCEPT'
`