Connect to Public Wifi Repeater

I currently have one openwrt device configured in ap mode and another openwrt device in sta mode. The device in ap advertises a public network without encryption. For some reason the device in sta mode is unable to connect to the access point. I have no issues connecting the sta device directly to a private network. I am also able to connect my laptop to the access point and load webpages so at least I know the access point is working.

This is the wireless config for the sta device:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel 'auto'
        option hwmode '11g'
        option path 'platform/10300000.wmac'
        option htmode 'HT20'
        option disabled '0'
config wifi-iface 'ap_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'sta'
        option ssid 'GW-AC233FC0A655'
        option encryption 'none'
config wifi-iface
        option network 'wan'
        option device 'radio0'
        option mode 'sta'
        option ssid 'GW-AC233FC0A61D'
        option key 'none'
        option encryption 'psk2'

So this one is on client mode.
That my own config as wireless client mode: Removed key and encryption.
For public hotspot with login and access code, I used relayd package.

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT40'
        option country 'US'
        option noscan '1'
        option channel '6'

config wifi-iface 'wifinet1'
        option ssid 'TP-LINK_5xxxx'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'

Are you trying to repeat a wifi hotspot or doing your own for say a hotel or something?

I do the former, I connect in client mode, it required me to white list the login page in rebind protection under DHCP & DNS screen.

Would it not make more sense to connect the second router via a wired connection and have it configured an an AP?

A regular STA (non WDS) can't be in a bridge such as the lan network. Change the network to wwan.

Two STA at the same time is not what you want here, also it can't work at all unless both APs are on the same channel. Disable one of them. The travelmate package can be used to automatically disable all your STA except the one for the preferred network that is in range.

1 Like