Connect to orange fibre in spain

Hi

I am trying to use a WDR3600 router to connect to the internet. I have a fibre connection from orange in spain and I would like to get rid of the orange Livebox.

Not sure how to connect the wan port. I have been reading, that I should use PPPoE for the connection via VLAN 832.

So, first of all, I modified the switch settings, to use 832 for the VLAN:

Then I did the settings for the PPPoE, see /etc/config/network in the bottom of this message.

But when I connect, the PPPoE says: Error: Connection attempt failed

Any ideas how to proceed or what to change

Cheers

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.0.0.1'

config interface 'wan'
	option ifname 'eth0.832'
	option proto 'pppoe'
	option username 'orangeuser@orangeadsl'
	option password 'orangeuser123'
	option ipv6 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '832'
	option ports '0t 1t'

Make sure you read this and verify with swconfig that vlan is added correctly.

thanks @trendy, this is what I have (IMHO looks good, no?):

# swconfig dev switch0 vlan 1 show
VLAN 1:
	vid: 1
	ports: 0t 2 3 4 5 

# swconfig dev switch0 vlan 2 show
VLAN 2:
	vid: 832
	ports: 0t 1t 

Yes, looks good.
Now fire up tcpdump and paste here the output:
tcpdump -i eth0.832 -nnv
While you are running it try to make WAN interface connect.

i got:

# tcpdump -i eth0.832 -nnv
tcpdump: listening on eth0.832, link-type EN10MB (Ethernet), capture size 262144 bytes
19:19:14.707299 PPPoE PADI [Service-Name]
19:19:19.708000 PPPoE PADI [Service-Name]
tcpdump: pcap_loop: The interface went down
2 packets captured
2 packets received by filter

does not look like much ...

french forum for replace a livebox:

https://lafibre.info/remplacer-livebox/

but .. I do not see what it will bring you …

i have a livebox 4 1G/300M with fiber + a TVUHD ( wifi 5G with repeater )

Indeed, you are initiating a connection but no offer from server.
I am not sure if frames are really tagged or if there is some other issue.

@F5BJR: Thank you for the link, i once stumbled upon that. They speak about the "identifiant". I have, as I mentioned above, a username and a password. I tried it anyway now with (just by using orangeuser@orangeadsl in sendopts without the password):

config interface 'wan'
	option ifname 'eth0.832'
        option proto 'dhcp'
        option broadcast '1'
        option vendorid 'sagem' # on envoi le vendor id sagem
        option reqopts '1 15 28 51 58 59 90' # liste des options
        option sendopts '77:2b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e4c697665626f7834 90:000000000000
00000000001a0900000558010341010d6f72616e676575736572406f72616e67656164736c'

and i get:

19:33:47.327668 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 396)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from c4:e9:84:e9:0e:c5, length 368, xid 0x2e1b9b3e, secs 12, Flags [Broadcast]
	  Client-Ethernet-Address c4:e9:84:e9:0e:c5
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    MSZ Option 57, length 2: 576
	    Parameter-Request Option 55, length 12: 
	      Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
	      Domain-Name, BR, NTP, Lease-Time
	      RN, RB, AUTH, Classless-Static-Route
	    Vendor-Class Option 60, length 5: "sagem"
	    Hostname Option 12, length 6: "pertus"
	    User-Class Option 77, length 44: 
	      instance#1: "FSVDSL_livebox.Internet.softathome.Livebox4", length 43
	    AUTH Option 90, length 43: 0.0.0.0.0.0.0.0.0.0.0.26.9.0.0.5.88.1.3.65.1.13.111.114.97.110.103.101.117.115.101.114.64.111.114.97.110.103.101.97.100.115.108
19:33:50.328179 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 396)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from c4:e9:84:e9:0e:c5, length 368, xid 0x2e1b9b3e, secs 15, Flags [Broadcast]
	  Client-Ethernet-Address c4:e9:84:e9:0e:c5
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    MSZ Option 57, length 2: 576

which somehow looks more promising

Orange Spain is DHCP and vlan 832 tagged WAN when it's a direct line.

If it is NEBA( this is when Orange doesn't have a direct line to your area) it's vlan 20 tagged.

1 Like

Not really, it is the same thing but in DHCP protocol. You sent 2 discover packets, but didn't get any offers.

This isn't really on topic, but the terms "fibre" and "tl-wdr3600" raise kind of an alarm sign, as the tl-wdr3600 is only good for around 130-150 MBit/s routing throughput (it should be possible to make it work, but its performance is limited to around that ballpark).

Unfortunately, the terms "fibre" and "more than 100MBps" do not always come together ;).

2 Likes

Those who wet their feet in the Mediterranean pond know best that fibre is usually to the cabin and you get a decent VDSL :smiley:

ok, i now did it the other way around. I connected the Orange router to mine and did the tcpdump, so I see the request the original router is doing. i now try to fiddle the needed options out of this:

    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 4c:09:d4:7f:76:03, length 334, xid 0x3e8de566, secs 21974, Flags [Broadcast]
	  Client-Ethernet-Address 4c:09:d4:7f:76:03
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    Vendor-Class Option 60, length 8: "arcadyan"
	    Client-ID Option 61, length 7: ether 4c:09:d4:7f:76:03
	    Requested-IP Option 50, length 4: 0.0.0.0
	    Hostname Option 12, length 7: "Livebox"
	    Domain-Name Option 15, length 4: "home"
	    Parameter-Request Option 55, length 4: 
	      Default-Gateway, Subnet-Mask, Domain-Name-Server, Domain-Name
	    User-Class Option 77, length 42: 
	      instance#1: "FSVDSL_livebox.Internet.arcadyan.Livebox1", length 41

Option 77 seems a bit off from what the Orange router sends. You can also try to change the hostname into "Livebox".

@Gingernut: And 20 it is! Thanks

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.