Connect to OpenWrt device with missing DHCP packages

Hi everyone,

I'm trying to recover and connect to the mis-configured device which isn't able to get the IP assigned.

What kind of mistake I made:
I was building mesh network using TP-Link devices: One Archer C6 and two repeaters RE200. I've built custom images without unnecessary packages for both devices. RE200 image has no firewall, dhcpd, etc. as it has static IP pre-configured.

While setting up the second repeater, I, instead of the following sequence

flash openwrt standard -> configure network -> flash custom image

I did:

flash custom image -> reboot -> brick

As 'lan' is most likely configured as DHCP server -> LAN port isn't available and WLAN is disabled. I basically can't find the device in network.

Any ideas how I can still SSH to the device to configure the network?

AFAIK RE200 doesn't support tftp flashing, so I see no easy way to flash the standard image

if the LAN port isn't available, how are you going to connect to it ?

I was thinking about the Link-local address, hoping that's it's still accessible.

All obvious solutions are out, so I'm asking for something less trivial to solve this. It's hard to believe that there's no way to un-brick

I was initially going to suggest arp, but if the LAN port's dead ....

Have you tried failsafe mode? Not sure if it works with custom images and configuration baked in though, but it's worth a try


That was a great suggestion! Failsafe mode worked - network restored. Thank you!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.