Connect to OpenVPN Provider dont change the IP

Hallo,

i successful connect with OpenVPN to my VPN provider but the ip address do not change and i still have the same ip address from my ISP and not from the VPN.

I followed and practice this guide for config : https://www.vpnunlimitedapp.com/en/info/manuals/openwrt-on-asus

The configuration is configured as a Client routed point to point VPN
Here is my Openvpn config:

config openvpn 'VPN_Unlimited'
	option nobind '1'
	option port '1194'
	option dev_type 'tun'
	option keepalive '5 30'
	option persist_tun '1'
	option persist_key '1'
	option client '1'
	option proto 'udp'
	option ca '/etc/ca.key'
	option cert '/etc/cert.key'
	option key '/etc/key.key'
	option auth 'SHA512'
	option cipher 'AES-256-CBC'
	option verb '3'
	option remote_cert_tls 'server'
	option dev 'tun'
	list tls_cipher 'TLS-RSA-WITH-AES-256-CBC-SHA'
	list remote 'vpnunlimitedapp.com'
	option remote_random '1'
	option comp_lzo 'no'
	option enabled '1'

This is the network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd42:7701:083e::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.189.1'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'
        option peerdns '0'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'VPN_U'
        option proto 'none'
        option ifname 'tun0'
        option delegate '0'

This is the firewall config:

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'DROP'
        option forward 'DROP'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option family 'ipv4'
        list icmp_type 'echo-request'
        option target 'DROP'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

config include 'bcp38'
        option type 'script'
        option path '/usr/lib/bcp38/run.sh'
        option family 'IPv4'
        option reload '1'

config zone
        option name 'VPNU_FW'
        option network 'VPN_U'
        option output 'ACCEPT'
        option forward 'REJECT'
        option input 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'VPNU_FW'

config forwarding
        option src 'wan'
        option dest 'VPNU_FW'

config forwarding
        option src 'VPNU_FW'
        option dest 'lan'

config forwarding
        option src 'VPNU_FW'
        option dest 'wan'

The last forwarding rules are an experiment by me, i tried to open and forward everything but with 0 effect.

Please help me to find out what is wrong in my configuration, i spend more then 5 hours and i can't find it out.

Best Regards
Vla

What do you mean IP doesn’t change?

The ISP-assigned IP doesn’t change.

Yes i mean the IP from the ISP dont change to the new from VPN. I have now edit the post to be clear

A VPN adds IP addresses. Your ISP address won’t and can’t change if you expect to stay connected.

1 Like

So with OpenVPN i can not get an IP from other Countrys as example to watch Netflix US? Iam in Austria.

Your ISP address does not change

Your VPN provides an additional IP address that is “on the server”

I can’t comment on if Netflix blocks your VPN provider. I have read that they block many now.

1 Like

Ok, thank you jeff. I have to find than an other way for geoblocking restricts. Did think OpenVPN can help me in this case.