Connect Flint 2 to modem with bridge mode

Hi guys, I just got a Flint 2 to hopefully solve the terrible bufferbloat issue I have on my network. I rooted my ISP modem (necessary because of DSL and VOiP home phones) in order to access bridge mode on it. Now that my modem is in bridge mode, how do I connect the Flint 2 so that it acts as the only router? My ISP modem only has to act as modem and VOiP server, everything internet related has to run through the Flint 2 in order to use SQM. Thanks!

Normally, you simply set the wan connection protocol appropriately. By default, OpenWrt sets it to DHCP. If your modem requires a PPPoE termination, change the setting on the wan interface to PPPoE and enter the credentials.

How do I know if it requires PPPoE termination? Also which ports do I need to plug the ethernet cable in on each side? LAN1 in modem and WAN in the Flint 2?
EDIT: also, I don't need to turn on UPnP, disable firewall and stuff like that in the modem right? It's disabled automatically once put in bridge mode, or am i wrong?

Theoretically it would be information available from (ideally previously provided by) your ISP. If DHCP doesn't work, you probably need PPPoE.

Yeah, that would be the expected connection.

Presumably not. But we don't know anything about your modem.

Bridge mode would normally mean that the either the raw connection (in the case of PPPoE required on your modem) or otherwise the IP address from the ISP would pass directly to the next connected device (I.e. your Flint 2). But it all depends on how your modem implements bridge mode.

Sorry for the late reply, but I didn't have time do any attempt. Today I tried to connect the modem to the Flint 2, failing. I activated Bridge Mode on the modem (TIM Hub [ AGTHP DGA4132 (VBNT-S)], rooted with Ansuel GUI installed). Once activated it asked me which kind of bridge mode: DHCP, Static or PPPoE. I have no idea what to do honestly. I really need a detailed guide for configuration on both sides, I've little to no experience when it comes to networking

You'll need to ask the manufacturer or the people who provided the instructions for rooting your device to understand exactly what the modem is doing in each of those modes. Those don't really seem like bridging modes -- they seem more like the standard connection methods.

Your modem is not running OpenWrt, so it is out of scope for this forum. Once you figure out a) the correct settings for your modem, and b) the expected settings for the downstream device, we can help you with the implementation of item b on your OpenWrt config.

Can you tell me what needs to be done on the Flint 2, so I can start setting it up? Don't leave out any useful detail because I'll need them all ahah. Unfortunately the forum for that GUI is not very responsive, so I'm still waiting. If i know the Flint 2 is ready to be used tho, I can trial and error on the modem knowing it's going to be the only thing causing problems

I am assuming that you are running official OpenWrt (i.e. it was downloaded from openwrt.org). If you're still using the GL-Inet firmware, you need to either ask on their forums or consider installing the official OpenWrt from here.

That said, from a default configuration of official OpenWrt, very little is necessary.

  • Most users will want to enable wifi (set the country code, SSID, encrpytion type, passphrase, and then enable the radios).
  • If your modem is actually providing routing/NAT (and not a true bridge), you'll also need to make sure that the modem's subnet does not overlap with the OpenWrt lan (default 192.168.1.0/24). If it does overlap, you can change the subnet to something else (for example, set the OpenWrt lan to 192.168.5.1).
  • If the wan connection protocol required by your modem or ISP is not DHCP, you'll change it to PPPoE or Static IP. These would require information that you'd need to get from your ISP -- we wouldn't have that information here.

It should be, aside from the things I mentioned above.

This is what the ISP page says

  • USERNAME: phone_number
  • PASSWORD: timadsl
  • PROTOCOL: PPPoE Routed (defined as RFC 2516)
  • encapsulation: PTM
  • NAT: active
  • VLAN: 835
  • IGMP proxy: disabled
  • Routing: unicast traffic

So that's PPPoE. You'll need to change the protocol on the wan interface to PPPoE and input the credentials. The device will also need to be changed to wan.835 such that it uses VLAN 835.

There's something weird going on. If I connect the Flint 2 static and don't touch anything on the modem, it works. The second i turn on bridge pppoe it goes nuts, to the point where not even the modem can reconnect to internet anymore. These damn isp modems