Connect a WRT3200acm's to internet through it's WAN port

Hi, I'm new to OpenWRT.

I have a working set up (using the original firmware) where my wrt3200 ACM is connected to the internet through its WAN port, plugged into an Xfinity router, which has been configured into bridged mode.

I successfully installed OperWRT latest version, but was not able to connect the router to the internet through the WAN port (all the rest was working fine), and did not have the switch menu available to try hacking... So luckily I was able to revert by booting the original partition from ssh.

Can someone kindly advise what I may be missing, to have my setup working with OpenWRT as well?

Thanks for any help!

Should work out of the box unless...

1 your WANs MAC for some reason differs between stock fw and openwrt

2 you're double NATed, and the primary router uses the same LAN subnet as your 3200, running openwrt.

Thank you for your prompt response!

Yep... I too was expecting it to work out of the box, just like with the original firmware.

The WAN Mac is exactly the same in openwrt as in the original firmware.

No double NATing, just the connection to the bridged router to Xfinity cable on one side and my internal network on the private side.

Also, I did not changed anything in the setup, in fact reverting to the original partition just restored everything working like as if I didn't even flash openwrt.
Moreover, I also did not do any fancy changes in openwrt: I just installed it, configured the administrative password and set up the Wi-Fi connections (letting them disabled).

In the interfaces I can see are the LAN, WAN and Wan6 interfaces (btw, no switch menu!!). The WAN has the same Mac address but does not have any IP address assigned to it.
All the LAN/WI-FI interfaces work okay in the private Network... Just the WAN does not connect to the internet...

Thanks again for any help!

Your device uses DSA instead of swconfig. This means there will be no switch menu.

Try restarting your cable modem -- maybe even a few times.

1 Like

Thanks, yesterday night I did that like at least 10 times, with different intervals up to 20 minutes, because I thought there was something cashed in the bridge router... But no luck.

The very strange thing was that as soon as I reverted the partition with the original firmware everything worked perfectly without the need of any restart.. . And even stranger we're talking about the same physical hardware connected... And the rotor itself is showing that it is connected to the internet through its LED.

To be sure of MAC check what OEM has, and what your OpenWrt install of config /etc/config/network set:

config device
	option name 'wan'
	option macaddr 'xx:xx...'

make the same if not.

1 Like

Ok I'll flash it again and double check as you suggested, will report back as soon as I did. Thanks!

You can just use the power switch to go to the other partition.

Ah wonderful, this is a new one! I did not see this in the wiki!! Can you please point me to the link with the instructions or just let me know how it exactly works?

Same process

1 Like

I just checked but I forgot that the router just has a power switch.. are you intending the reset button?

maybe try disabling wan6 and ipv6 on the wan interface.
i think that even though the WAN ipv4 mac may be the same, the cable modem might be looking for a persistent ipv6 adress downstream, which might be different in openwrt than the oem firmware. and did you power down your cable modem for long enough that it might 'forget' the downstream hardware?

Ah great, I'll try it out the, thanks!!

Got it, I'll try that as well! Thanks!

I finally got this solved: I turned off the xfinity modem and just left Costco-ing, when I came back, I turned it on and... voila'!!
It was indeed some ipv6 caching of some sort as @psherman and @ghoffman suggested.

I want to thank all for your helpful suggestions, which all contributed to both clarifying options on my scenario and leading me to the solution!! @anomeome @psherman @ghoffman @frollic @RuralRoots, THANK YOU!!

This firmware is simply terrific and is giving new life to my WRT3200acm. Thanks to all the community for putting this out!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.