Connect 2 local subnets with a static ip on one

Hello. I have 2 local subnets. The WAN side of the router has a DHCP server assigned ip of 192.168.13.101.The pc on the LAN side is static 192.168.0.251. I am not able to ping 192.168.13.100 (which is the server i need to talk to) from 192.168.0.251 with my pc when using a static ip but can if I use the routers DHCP to get the ip. I did an ipconfig /all when using DHCP to get the info needed to switch to static. I assume its a setting on the router which currently has the default settings other than changing the LAN ports ip. Thank you.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@GL-SFT1200:~# ubus call system board
{
        "kernel": "4.14.90",
        "hostname": "GL-SFT1200",
        "system": "MIPS sf19a28",
        "model": "GL-SFT1200",
        "board_name": "glinet,gl-sft1200",
        "release": {
                "distribution": "OpenWrt",
                "version": "LEDE",
                "revision": "r0-d5ed025",
                "codename": "",
                "target": "siflower\/sf19a28-fullmask",
                "description": "OpenWrt  18.06"
        }
}
root@GL-SFT1200:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbb:38b1:9dd3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option hostname 'GL-SFT1200-fc1'
        option ipaddr '192.168.0.250'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '94:83:c4:43:7f:c2'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option hostname 'GL-SFT1200-fc1'
        option ipv6 '0'
        option metric '10'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '94:83:c4:43:7f:c1'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
        option disabled '1'

config interface 'guest'
        option ifname 'guest'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option group '0'
        option forcelink '1'
        option ipaddr '192.168.9.1'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'

config switch_port
        option device 'switch0'
        option port '5'
        option pvid '2'

config interface 'wwan'
        option proto 'dhcp'
        option metric '20'
root@GL-SFT1200:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option txpower '25'
        option txpower_max '25'
        option band '5G'
        option hwmode '11a'
        option noscan '0'
        option netisolate '0'
        option max_all_num_sta '64'
        option path 'platform/17800000.wifi-hb'
        option htmode 'VHT80'
        option disabled '0'
        option country 'US'
        option acs_noradar '1'
        option channel '48'
        option org_htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option hidden '0'
        option ifname 'wlan0'
        option wpa_group_rekey '36000'
        option isolate '0'
        option group '1'
        option disable_input '0'
        option wps_pushbutton '1'
        option wps_label '0'
        option ssid 'GL-SFT1200-fc1-5G'
        option encryption 'psk2'
        option key 'goodlife'
        option disassoc_low_ack '0'
        option wds '1'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option txpower '20'
        option txpower_max '20'
        option band '2.4G'
        option hwmode '11g'
        option noscan '0'
        option netisolate '0'
        option max_all_num_sta '64'
        option path 'platform/11000000.wifi-lb'
        option htmode 'HT40'
        option country 'US'
        option channel '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option hidden '0'
        option ifname 'wlan1'
        option wpa_group_rekey '36000'
        option isolate '0'
        option group '1'
        option disable_input '0'
        option wps_pushbutton '1'
        option wps_label '0'
        option ssid 'GL-SFT1200-fc1'
        option encryption 'psk2'
        option key 'goodlife'
        option wds '1'
        option disassoc_low_ack '0'
        option disabled '1'

config wifi-iface 'guest5g'
        option device 'radio0'
        option network 'guest'
        option mode 'ap'
        option wds '1'
        option ssid 'GL-SFT1200-fc1-Guest-5G'
        option encryption 'psk2'
        option key 'goodlife'
        option ifname 'wlan2'
        option disabled '1'
        option guest '1'
        option disassoc_low_ack '0'

config wifi-iface 'guest2g'
        option device 'radio1'
        option network 'guest'
        option mode 'ap'
        option wds '1'
        option ssid 'GL-SFT1200-fc1-Guest'
        option encryption 'psk2'
        option key 'goodlife'
        option ifname 'wlan3'
        option disabled '1'
        option guest '1'
        option disassoc_low_ack '0'
root@GL-SFT1200:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option leasetime '12h'
        option force '1'
        option dhcpv6 'disabled'
        option ra 'disabled'
        option start '251'
        option limit '4'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option dhcpv6 'disabled'
        option ra 'disabled'

config domain 'localhost'
        option name 'console.gl-inet.com'
        option ip '192.168.0.250'

config host '50A0300C48BD'
        option mac '50:A0:30:0C:48:BD'
        option ip '192.168.0.136'

You appear to be running the GL-inet vendor firmware (and ancient at -- what you've got is based on LEDE 17.01).

You need to ask GL-Inet using their support channels or user forums for help.

Ok. Thank you

I think you are missin gateway in your lan configuration (on PC).

This topic was automatically closed after 2 hours. New replies are no longer allowed.