Confusion over wireless

I was way behind on the firmware, and couldn't get anything that used to work working, so I flashed the latest and the problem persists. I'm also not a network guy, but at least a long retired engineer.

I have a GL-inet MT300N V2 that I'm using with the Wifi working a a client from a cellphone hotspot and the LAN driving a laptop(will eventually be a router). I'm trying to create a backup connection when our normal ISP goes down.

I wiped the config when I flashed (on purpose) and when I "scan" the radio0, I can configure my wifi hotspot and it sometimes works. If I configure a second wifi client for another hotspot, I can see the network switching between the phones as I turn the hotspots on/off. Most of the time, the LAN doesn't work, and it seems to be correlated to the "?" in the Hosts column of the Associated Stations. My laptop can't seem to find a DNS according to the MS Troubleshooter. Maybe I need to define DNSs on the target rather than using OpenWRTs DHCP?

The config is at default except for the LAN IP/Mask. I've tried unchecking Domain Req'd for DNS, and have added in DNS Forwardings, neither of which helps (so I restored them to default).

I put this device together in 2019 and never had the need to use it. Can't claim it worked back then, but it is very sketchy right now.

You might find something in the system logs to indicate an issue.
You can check in the GUI or ssh and do logread; logread -f

That displays recent entries and then starts a follow.

Default config should be fine. I would reboot the router and the laptop between connecting to different hotspots. Also flush your browser cache etc.. Also you might want to reset the router so you can start over from default config.