Confusion over how to configure LEDE to use pihole on a separate device

I have pihole running on a separate device ( I went to Network>Interface>LAN>General and populated that IP address for the Use custom DNS servers blank. I see requests in the pihole webUI but they are not getting blocked on the devices.

EDIT: If I look at my phone, I see it is not using that DNS entry... it is using the default of so I must not have LEDE setup correctly. Any tips are appreciated.

I believe what you want do is advertise a different DNS server to your LAN's clients. Under Network - Interfaces - LAN - Edit - DHCP Server - DHCP-Options enter 6,

FlushDNS or reboot devices and check to see if the new DNS server is shown. You could also add a comma and as a second backup DNS just in case your Pi-hole is ever offline.

Check this post under "Modify DNS to Prevent Leaks" (you'll need to scroll down) for an image of the relevant LuCI page:

Let me know if that does the trick.

1 Like

Yes! This did the trick. Thank you.

As an aside for others reading this thread in the future, my pihole box runs on a subnet (guestzone). To get this to work I had to complete an extra setup:

Network>Firewall>Traffic Rules
Any udp
From any host in lan
To IP, port 53 in guestzone