Confused by eth0.x and 8021q

in openwrt 19.x, are these two configurations equivalent?
config 1

config device 'dev_wan3'
option name 'br-wan3'
option ifname 'eth0'
option type '8021q'
option vid '3'

config interface 'wan3'
option ifname 'br-wan3'
option proto 'static'
option ipaddr '3.3.3.3'
option netmask '255.255.255.0'

config2

config interface 'wan3'
option type 'bridge'
option ifname 'eth0.3'
option proto 'static'
option ipaddr '3.3.3.3'
option netmask '255.255.255.0'

Use OpenWRT23.05.4 and LuCI