Conflict with dependencies installing kmod-usb-net-asix

I've just installed OpenWRT 22.03.5 on a Raspberry Pi 4 B from the image openwrt-22.03.5-bcm27xx-bcm2711-rpi-4-squashfs-sysupgrade.img.gz

I have an ethernet adapter that is detected as Asix AX88179 by the system

[ 1103.856091] usb 2-1: new SuperSpeed Gen 1 USB device number 3 using xhci_hcd
[ 1103.892734] usb 2-1: New USB device found, idVendor=0b95, idProduct=1790, bcdDevice= 1.00
[ 1103.900924] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1103.908073] usb 2-1: Product: AX88179
[ 1103.911734] usb 2-1: Manufacturer: ASIX Elec. Corp.

I'm trying to install the driver but I've got a dependency error issue.

root@OpenWrt:~# opkg install kmod-usb-net-asix
Unknown package 'kmod-usb-net-asix'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-libphy
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-libphy found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-phy-ax88796b
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-phy-ax88796b found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-mii
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-mii found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-nls-base
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nls-base found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-usb-core
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-usb-core found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-usb-net
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-usb-net found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-usb-net-asix
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-usb-net-asix found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package kmod-usb-net-asix.

Same with the package kmod-usb-net-asix-ax88179:

root@OpenWrt:~# opkg install kmod-usb-net-asix-ax88179
Unknown package 'kmod-usb-net-asix-ax88179'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-libphy
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-libphy found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-mii
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-mii found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-nls-base
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nls-base found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-usb-core
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-usb-core found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-usb-net
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-usb-net found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.176-1-226c4dc22addf8a1948f0054a86ec23f) for kmod-usb-net-asix-ax88179
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-usb-net-asix-ax88179 found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package kmod-usb-net-asix-ax88179.

For what I've found in other posts, this usually happens with snapshots or self-compiled image, but in this case is the current stable release.

This is my information on the system:

root@OpenWrt:~# uname -a
Linux OpenWrt 5.10.176 #0 SMP Thu Apr 27 20:28:15 2023 aarch64 GNU/Linux

Am I doing something wrong?

Thanks.

A better alternative might be to use the firmware selector and add kmod-usb-net-asix-ax88179 to the list of custom packages to include in the build.

https://firmware-selector.openwrt.org/?version=22.03.5&target=bcm27xx%2Fbcm2711&id=rpi-4