Configuring Wifi on x86

I'd like to get Wifi access working under x86. Is there a handy guide?

This is straight forward for openwrt also on x86...
Ensure you have installed needed drivers and firmware files.

Check dmesg if you device gets detected.
If your device didn't show up if you execute iw list, then something is missing...
What is missing depends on you wifi hardware.

Check for available kernel moduls with:

opkg update
opkg list | grep kmod-

Hope this will get you a step forward.

If not let us know which wifi device you have attached and please provide a kernel bootlog.

1 Like

I'm not that familiar with Linux....

On FreeBSD I would run

pciconf -lv | grep network

which would show the network adapters. What is the equivalent on Linux?

iw list gave me - not found.

HDT tells me I have an Intel Centrino Advanced-N 6200 2x2 AGN

This is OpenWrt. You will likely need to install the drivers (common ones are listed on the pages found on the link above). You would install via the command opkg, then after reboot, you should have a WiFi Interface that you can configure.

Please be advised, most cards from Intel don't do Access Point Mode, only Client Mode. I would suggest an Atheros-based WiFi card.

1 Like

Indeed, Linux does not support AP mode on the Intel 6200 chipset.

The OpenWrt distribution x86 builds do not ship with any wifi drivers, since it is not possible to know what hardware the user will have, and many x86 installs do not use wifi at all.

The necessary driver packages are kmod-iwlwifi and iwlwifi-firmware. Again this will only have limited functionality. Once installed you can run iw list to show the capabilities of your driver / card combination.

1 Like

Thanks for the link to the wireless FAQ.

By default the wireless is OFF. Turn it on in /etc/config/wireless by changing disabled 1 ⇒ disabled 0

But there is no such file.

I installed iwlwifi and rebooted but see a msg about no suitable firmware found found for the wifi NIC

You will need iwlwifi-firmware-iwl6000g2, if the error still occurs, please post the dmesg output. On x86 there is no wireless daemon installed by default, so you have to install wpad manually for wireless configuration options to show up.
But as previous posters mentioned - you probably won't be able to use AP mode with your wifi chip.

Thanks. So far so good. I have enabled wifi in the wireless file and run /etc/init.d/network reload to restart network services but ifconfig does not show the new interface. Do I need to reboot?

And how do I get an IP address for the NIC? I'm using DHCP on a different system.

AP mode is not something I'm looking at currently. Just using this system for learning OpenWrt.

If your interface doesn't show up, a reboot won't hurt I guess.

To use client mode, you have to put option mode 'sta' into your device scction in /etc/config/wireless. Have a look at

Thanks. A network interface does show up but no IP address gets assigned. I guess my network file has something incorrectly setup. I couldn't find an example of a wifi entry in /etc/config/network.

Your wifi interface won't show up in /etc/config/network, the wifi configuration is only done in /etc/config/wireless. In your device section in /etc/config/wireless, you have to specify which network your device should connect to (one of the "interfaces" in /etc/config/network, this can be quite confusing at the beginning).
I've never set up an OpenWrt device as a wifi client, but to start I'd try to set option network 'wan' in your wifi device section and make the wan interface use DHCP. If it doesn't exist, create it manually by adding

config interface 'wan'
	option proto 'dhcp'

to /etc/config/network. That way the wan interface should get an IP address via DHCP once a wifi connection gets established.
If you use a different interface name, e.g. wwan, you will have to create firewall rules for this interface. If you just want to get an IP via DHCP, wan should work fine.

1 Like

6 posts were split to a new topic: Intel 2915ABG on x86

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.