Configuring Vlans for ISP services

Hello everyone, i recently switched ISP (From Caiway to Delta) and they supplied me with a modem that is not able to be put into bridge mode and the DMZ mode does not forward the public ip so i was not able to do anything from my lan that is running om my openwrt routers. After some discussions with my isp i decided to buy my own modem and the isp will configure it from their part so i can do everything from my own routers again. Now my ISP is using quite a specific type of fiber called xgs-pon so finding a modem was not to easy. I just received the modem and tried to install it with my ISP because they need to configure the id and mac but the modem is that new that they dont even have a config for it yet. The problem i am running into now that if the modem is operational alter i dont know how to configure the specific Vlans they want me to configure. Every time i configure a vlan on my router it kicks me out and i lose all access. I don't know how to configure them in a way that the rest of the network still works i can also translate the steps the ISP want's me to take if that is easier.

If anyone has done this before or knows how to do this help would be really appreciated!

Best regards,
Nick

This page describes the configurations for several ISPs, perhaps you can find yours there, or use it to understand how to build the configuration for your ISP:

https://openwrt.org/docs/guide-user/network/wan/isp-configurations

Otherwise, you can share here the parameters that your ISP needs you to use, and somebody will guide you.

Thank you i will look into it!
I have translated the requirements from my ISP:
P2P Fiber Network / XGSPON Fiber Network

For configuring IPv4 on the WAN interface, DHCP must be used. The following VLANs are used in the DELTA network:

  1. VLAN 100: Internet
  2. VLAN 101: TV
  3. VLAN 102: Voice

To achieve the best quality on TV streams, the following static routes must be configured on the customer’s device (modem/router):

Routing from the customer LAN to the following subnet must be routed via VLAN 100:

  • Source interface LAN to destination 62.45.57.36/32 via interface VLAN 100

Routing from the customer LAN to the following subnets must be routed via VLAN 101:

  • 62.45.57.34/32
  • 62.45.57.0/24
  • 62.45.59.0/24
  • 62.45.76.0/24
  • 62.45.58.226/32
  • 62.45.45.150/32
  • 62.45.49.0/24
  • 212.115.196.0/25
  • 217.63.90.128/25
  • 217.63.91.0/26
  • 62.45.61.32/27
  • 62.45.61.16/28
  • 62.45.61.64/28
  • 217.102.255.57/32

This is what the ISP writes to configure in the router but i dont really know how to translate this to openwrt. The new modem i am going to use is the TP-Link XGZ030. From what i got from the supplier the tp-link should be able to just be used to convert the fiber to lan and make the openwrt router do the rest

Everything seems pretty much standard, I think you will not have any issues to translate that to OpenWrt. I understand that you are starting with the default configuration, but could you share your "/etc/config/network" file here, please (mask or delete the sensitive information)?

Let's start with the internet connection, shall we? If you have a WAN interface configured as a DHCP client on eth0 (for example), you just need to move it to eth0.100.

Sure I have a spare router that i am configuring from scratch so when the system is online i hope to just plug it in so the file should just be basic.

Here is the network file

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'dont know if that was important but removed it'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.5.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

Edit the WAN and WAN6 interfaces, and change the device associated to "wan.100" on both of them.

1 Like

Thanks for your response im sorry i was a bit busy with work but i finally got time ill change the config

Great news, i just got my new modem programmed in by my ISP and i added the wan.100 to my interface like you said and i instantly got internet! so that is amazing thanks! now i am just wondering how i can add 101 and 102? because at this point in time my internet is slower than it is supposed to be. And another question i have is do i need to configure anything for the VLAN's in my managed switch and other dump-ap routers in my netwerk? (also openwrt)

1 Like

Configuring other VLANs will not make your internet any faster...

Do you have any SIP clients on your network, to use the VoIP service? Have you activated the IPTV service with your network, and have a player at home?

Noo i know by definition that is wont make it faster that is a given but i know from my previous test that i am amble to get around 850bit we pay for 1000bit and now i am down to 600bit. But at this point in time i have only configured vlan 100 which my isp provides/says for internet and to imporve the performace they say to add 101 for tv and 102 for voice. the tv is working on 100 and i dont have voice so that does not matter to much but how would i be able to configure the 101 for the tv?

The usually best way to handle ISP IPTV is to bypass the router entirely other than using the switch hardware to switch TV packets at layer 2 (based on their VLAN tag).
This works when you have an ISP provided TV box with an Ethernet port and the TV service still works with the box directly plugged into the ONT. Switching will emulate that connection but also allow your router to pull out Internet on a separate VLAN.

To do this switching in a DSA router you will need to set up full bridge-vlans instead of using the simple wan.100 method.

Creating the VoIP or IPTV interfaces will only move that part of the traffic there. If you speeds are bad when you are not watching TV of talking on the phone, creating those interfaces will not help there.