Configuring PBR with OpenVPN

I apologize if this is the wrong place to be posting for this.

I have successfully configured my WRT-3200 ACM router with OpenVPN and it is displaying the correct IP address across all my devices. While the VPN is enabled however, when I switch over to Policy Based Routing, it doesn't show any "checks" on the wan interface but it isn't showing me any errors either. Any IP addresses I add to the list and enable isn't doing anything and devices are still showing the public IP provided by the VPN. I tried using static IP addresses and MAC address, no luck. Any way I can split tunnel some devices that don't play nice with the VPN without much trouble?

My VPN details are as follows, maybe something stands out to anyone on this forum:

client
dev tun
proto udp

remote 108.62.49.157 1194
remote 108.62.49.157 4569
remote 108.62.49.157 80
remote 108.62.49.157 5060
remote 108.62.49.157 51820

remote-random
resolv-retry infinite
nobind

cipher AES-256-GCM

setenv CLIENT_CERT 0
tun-mtu 1500
mssfix 0
persist-key
persist-tun

reneg-sec 0

remote-cert-tls server
auth-user-pass /etc/openvpn/ProtonVPN.auth


<ca>
-----BEGIN CERTIFICATE-----
<<CERT INFO>>
-----END CERTIFICATE-----
</ca>

<tls-crypt>
-----BEGIN OpenVPN Static key V1-----
<<CERT INFO>>
-----END OpenVPN Static key V1-----
</tls-crypt>

-Pyro

I figured this out. For whatever reason, installing OpenVPN / PBR didn't auto-configure the tun0 interface like it did last time. I added this and it worked just fine.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.