Configuring network for WiFi and LAN

Hi everyone - thanks for all the help in past.
I now have a nice build running on my HLK-76888A modules.

These devices go onto a self-designed motherboard which adds (amongst other things) an Ethernet port.
The port is working - it gets an IP address from the DHCP server on my Lan.

The Goal
I would like my devices to connect to WiFi (Clientmode) and/or LAN - if both are present they should connect to both and get an IP address from both. Then, clients on my network should be able to connect to my device using either WiFi (Smartphones etc) or LAN (Laptops with no WiFi etc).

Whats Actually Happening
After boot my device has 2 IP addresses, which look correct, and I can ping the device on both adresses. However I can only make connections (SSH, SCP, etc) to the WiFi address - the other address refuses the connections. This is where I am lacking knowledge.

What I've Checked
Here is the contents of /etc/config/network

root@Banana:/etc# cat /etc/config/network 
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc2:2b63:959f::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'dhcp'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'ca:5a:5d:60:d2:e2'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'ca:5a:5d:60:d2:e3'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

config interface 'wwan'
	option proto 'dhcp'

And here is the output of ifconfig

root@Banana:/etc# ifconfig
br-lan    Link encap:Ethernet  HWaddr CA:5A:5D:60:D2:E2  
          inet6 addr: fe80::c85a:5dff:fe60:d2e2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:428 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:132983 (129.8 KiB)

eth0      Link encap:Ethernet  HWaddr 40:D6:3C:22:37:80  
          inet6 addr: fe80::42d6:3cff:fe22:3780/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2526 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1089 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:830398 (810.9 KiB)  TX bytes:269874 (263.5 KiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr CA:5A:5D:60:D2:E2  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:428 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:132983 (129.8 KiB)

eth0.2    Link encap:Ethernet  HWaddr CA:5A:5D:60:D2:E3  
          inet addr:192.168.8.121  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fd34:7e00:f7dc:dd00:c85a:5dff:fe60:d2e3/64 Scope:Global
          inet6 addr: fe80::c85a:5dff:fe60:d2e3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2486 errors:0 dropped:0 overruns:0 frame:0
          TX packets:533 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:770473 (752.4 KiB)  TX bytes:104725 (102.2 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:34 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5937 (5.7 KiB)  TX bytes:5937 (5.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 40:D6:3C:22:37:80  
          inet addr:192.168.8.122  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::42d6:3cff:fe22:3780/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2528 errors:0 dropped:0 overruns:0 frame:0
          TX packets:533 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:752595 (734.9 KiB)  TX bytes:106014 (103.5 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 42:D6:3C:22:37:80  
          inet6 addr: fe80::40d6:3cff:fe22:3780/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:508 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:161082 (157.3 KiB)

And here is the contents of /etc/config/dropbear

root@Banana:/etc# cat /etc/config/dropbear 
config dropbear
	option PasswordAuth 'on'
	option RootPasswordAuth 'on'
	option Port         '22'
#	option BannerFile   '/etc/banner'

So I think I should be able to connect from either address - but only the WiFi connection allows me to connect from a remote machine. Have I missed something?