Configuring IPv6 via PPPoE

Hi fellow users!

I have a PPPoE connection to my ISP and need some help configuring IPv6 over it.
The tech support of my ISP is practically non-existenet, but I have gathered from them that they do in fact support IPv6.
When I asked them for help with configuring it, they sent me a photo of some router settings which I am attaching here.

My current setup is:
Ethernet cable from ISP router --> My router (Asus RT-AC58U-OpenWRT 19.07) --> LAN devices
I do not have access to the ISP router. I am pretty new to networking and would like to request for some help with this!

Edit: Some basic details

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5b:2bdb:61d8::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_eth0_dev'
        option name 'eth0'
        option macaddr '88:d7:f6:a8:1d:d8'

config interface 'wan'
        option ifname 'eth1'
        option proto 'pppoe'
        option password '***'
        option ipv6 '1'
        option username '***'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        option mtu '1492'

config device 'wan_eth1_dev'
        option name 'eth1'
        option macaddr '88:d7:f6:a8:1d:dc'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option reqprefix 'auto'
        option reqaddress 'try'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config redirect 'adblock_dns_53'
        option name 'Adblock DNS, port 53'
        option src 'lan'
        option proto 'tcp udp'
        option src_dport '53'
        option dest_port '53'
        option target 'DNAT'

config redirect 'adblock_dns_853'
        option name 'Adblock DNS, port 853'
        option src 'lan'
        option proto 'tcp udp'
        option src_dport '853'
        option dest_port '853'
        option target 'DNAT'

config redirect 'adblock_dns_5353'
        option name 'Adblock DNS, port 5353'
        option src 'lan'
        option proto 'tcp udp'
        option src_dport '5353'
        option dest_port '5353'
        option target 'DNAT'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'udp'
        option dest_port '547'
        option name 'Allow DHCPv6 (546-to-547)'
        option family 'ipv6'
        option src_port '546'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option name 'Allow DHCPv6 (547-to-546)'
        option family 'ipv6'
        option src_port '547'

Using adblock, dnscryptv2 and SQM

At first sight, everything looks fine... What is the output of "if config"? What do the logs say when you restart the WAN interface?

Hi @eduperez!

Here is the output of ifconfig:

br-lan    Link encap:Ethernet  HWaddr 88:D7:F6:A8:1D:D8
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fd5b:2bdb:61d8::1/60 Scope:Global
          inet6 addr: fe80::8ad7:f6ff:fea8:1dd8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:366192 errors:0 dropped:0 overruns:0 frame:0
          TX packets:535979 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:69762236 (66.5 MiB)  TX bytes:331990537 (316.6 MiB)

eth0      Link encap:Ethernet  HWaddr 88:D7:F6:A8:1D:D8
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:62273 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:14655640 (13.9 MiB)

eth1      Link encap:Ethernet  HWaddr 88:D7:F6:A8:1D:DC
          inet6 addr: fe80::8ad7:f6ff:fea8:1ddc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23631266 errors:0 dropped:6021 overruns:0 frame:0
          TX packets:16891725 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:919593427 (876.9 MiB)  TX bytes:1250220639 (1.1 GiB)

ifb4eth1  Link encap:Ethernet  HWaddr 9A:62:C5:25:63:AB
          inet6 addr: fe80::9862:c5ff:fe25:63ab/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:23629675 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23629675 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:22392459401 (20.8 GiB)  TX bytes:22392459401 (20.8 GiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:40385 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40385 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4510104 (4.3 MiB)  TX bytes:4510104 (4.3 MiB)

pppoe-wan Link encap:Point-to-Point Protocol
          inet addr:10.32.34.45  P-t-P:103.218.102.26  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:533459 errors:0 dropped:0 overruns:0 frame:0
          TX packets:362790 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:324435391 (309.4 MiB)  TX bytes:69202773 (65.9 MiB)

wlan0     Link encap:Ethernet  HWaddr 88:D7:F6:A8:1D:D8
          inet6 addr: fe80::8ad7:f6ff:fea8:1dd8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:223933 errors:0 dropped:0 overruns:0 frame:0
          TX packets:259722 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:53829788 (51.3 MiB)  TX bytes:231530563 (220.8 MiB)

wlan1     Link encap:Ethernet  HWaddr 88:D7:F6:A8:1D:DC
          inet6 addr: fe80::8ad7:f6ff:fea8:1ddc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:152789 errors:0 dropped:0 overruns:0 frame:0
          TX packets:290131 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:22622171 (21.5 MiB)  TX bytes:114080444 (108.7 MiB)

Here is the system log of the wan interface starting up:

Tue Jun 23 16:36:42 2020 daemon.notice netifd: Interface 'wan' is enabled
Tue Jun 23 16:36:42 2020 daemon.notice netifd: Network device 'eth0' link is up
Tue Jun 23 16:36:42 2020 daemon.notice netifd: Network device 'lo' link is up
Tue Jun 23 16:36:42 2020 daemon.notice netifd: Interface 'loopback' has link connectivity
Tue Jun 23 16:36:42 2020 daemon.notice netifd: Network device 'eth1' link is up
Tue Jun 23 16:36:42 2020 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Jun 23 16:36:42 2020 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 23 16:36:42 2020 daemon.err insmod: module is already loaded - slhc
Tue Jun 23 16:36:42 2020 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 23 16:36:42 2020 daemon.err insmod: module is already loaded - pppox
Tue Jun 23 16:36:42 2020 daemon.err insmod: module is already loaded - pppoe
Tue Jun 23 16:36:42 2020 daemon.info pppd[9631]: Plugin rp-pppoe.so loaded.
Tue Jun 23 16:36:42 2020 daemon.info pppd[9631]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Tue Jun 23 16:36:42 2020 daemon.notice netifd: radio1 (9533): command failed: Not supported (-95)
Tue Jun 23 16:36:42 2020 user.notice mac80211: Failed command: iw phy phy1 set distance 0
Tue Jun 23 16:36:42 2020 daemon.notice netifd: radio0 (9531): command failed: Not supported (-95)
Tue Jun 23 16:36:42 2020 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Tue Jun 23 16:36:42 2020 daemon.notice pppd[9631]: pppd 2.4.7 started by root, uid 0
Tue Jun 23 16:36:42 2020 daemon.info pppd[9631]: PPP session is 25136
Tue Jun 23 16:36:42 2020 daemon.warn pppd[9631]: Connected to 00:96:f1:1e:43:52 via interface eth1
Tue Jun 23 16:36:42 2020 kern.info kernel: [160164.498658] pppoe-wan: renamed from ppp0
Tue Jun 23 16:36:42 2020 daemon.info pppd[9631]: Renamed interface ppp0 to pppoe-wan
Tue Jun 23 16:36:42 2020 daemon.info pppd[9631]: Using interface pppoe-wan
Tue Jun 23 16:36:42 2020 daemon.notice pppd[9631]: Connect: pppoe-wan <--> eth1
Tue Jun 23 16:36:42 2020 daemon.info pppd[9631]: Remote message: Login ok
Tue Jun 23 16:36:42 2020 daemon.notice pppd[9631]: PAP authentication succeeded
Tue Jun 23 16:36:42 2020 daemon.notice pppd[9631]: peer from calling number 00:96:F1:1E:43:52 authorized
Tue Jun 23 16:36:42 2020 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Tue Jun 23 16:36:42 2020 daemon.notice pppd[9631]: local  IP address 10.32.34.45
Tue Jun 23 16:36:42 2020 daemon.notice pppd[9631]: remote IP address 103.218.102.26
Tue Jun 23 16:36:42 2020 daemon.notice pppd[9631]: primary   DNS address 8.8.8.8
Tue Jun 23 16:36:42 2020 daemon.notice pppd[9631]: secondary DNS address 103.14.232.100
Tue Jun 23 16:36:43 2020 daemon.notice netifd: Network device 'pppoe-wan' link is up
Tue Jun 23 16:36:43 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Tue Jun 23 16:36:43 2020 daemon.notice netifd: Interface 'wan6' is enabled
Tue Jun 23 16:36:43 2020 daemon.notice netifd: Network alias 'pppoe-wan' link is up
Tue Jun 23 16:36:43 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Jun 23 16:36:43 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Tue Jun 23 16:36:43 2020 daemon.notice netifd: Interface 'wan' is now up
Tue Jun 23 16:36:43 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Tue Jun 23 16:36:43 2020 user.notice firewall: Reloading firewall due to ifup of wan (pppoe-wan)
Tue Jun 23 16:36:44 2020 daemon.info dnsmasq[9474]: exiting on receipt of SIGTERM
Tue Jun 23 16:36:44 2020 authpriv.warn dropbear[10288]: Failed listening on '22': Error listening: Address not available
Tue Jun 23 16:36:44 2020 authpriv.info dropbear[10288]: Not backgrounding
Tue Jun 23 16:36:44 2020 kern.warn kernel: [160166.204972] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Tue Jun 23 16:36:44 2020 kern.warn kernel: [160166.205020] ath10k_ahb a800000.wifi: msdu-desc: 2500  skid: 32
Tue Jun 23 16:36:44 2020 kern.info kernel: [160166.240426] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Tue Jun 23 16:36:44 2020 kern.info kernel: [160166.241356] ath10k_ahb a800000.wifi: wmi print 'free: 56528 iram: 23400 sram: 32520'
Tue Jun 23 16:36:44 2020 kern.warn kernel: [160166.507245] ath10k_ahb a800000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Tue Jun 23 16:36:44 2020 kern.info kernel: [160166.507478] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
Tue Jun 23 16:36:44 2020 kern.info kernel: [160166.517733] br-lan: port 1(eth0) entered blocking state
Tue Jun 23 16:36:44 2020 kern.info kernel: [160166.523452] br-lan: port 1(eth0) entered forwarding state
Tue Jun 23 16:36:44 2020 daemon.err odhcpd[970]: Failed to send to ff02::1%lan@br-lan (Address not available)
Tue Jun 23 16:36:44 2020 daemon.err odhcp6c[9856]: Failed to send RS (Permission denied)
Tue Jun 23 16:36:44 2020 kern.info kernel: [160166.529372] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Tue Jun 23 16:36:44 2020 daemon.notice netifd: bridge 'br-lan' link is up
Tue Jun 23 16:36:44 2020 daemon.notice netifd: Interface 'lan' has link connectivity
Tue Jun 23 16:36:44 2020 daemon.info dnsmasq[10249]: started, version 2.80 cachesize 150
Tue Jun 23 16:36:44 2020 daemon.info dnsmasq[10249]: DNS service limited to local subnets
Tue Jun 23 16:36:44 2020 daemon.info dnsmasq[10249]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Tue Jun 23 16:36:44 2020 daemon.info dnsmasq-dhcp[10249]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Tue Jun 23 16:36:45 2020 daemon.err odhcp6c[9856]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Tue Jun 23 16:36:46 2020 kern.warn kernel: [160168.025570] ath10k_ahb a000000.wifi: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Tue Jun 23 16:36:46 2020 kern.warn kernel: [160168.025650] ath10k_ahb a000000.wifi: msdu-desc: 2500  skid: 32
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.060281] ath10k_ahb a000000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.061121] ath10k_ahb a000000.wifi: wmi print 'free: 56528 iram: 23400 sram: 32520'
Tue Jun 23 16:36:46 2020 kern.warn kernel: [160168.329477] ath10k_ahb a000000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.329736] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.339807] br-lan: port 2(wlan1) entered blocking state
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.345676] br-lan: port 2(wlan1) entered disabled state
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.351366] device wlan1 entered promiscuous mode
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.356604] br-lan: port 3(wlan0) entered blocking state
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.361043] br-lan: port 3(wlan0) entered disabled state
Tue Jun 23 16:36:46 2020 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: using local addresses only for domain test
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: using local addresses only for domain onion
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: using local addresses only for domain localhost
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: using local addresses only for domain local
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: using local addresses only for domain invalid
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: using local addresses only for domain bind
Tue Jun 23 16:36:46 2020 daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
Tue Jun 23 16:36:46 2020 kern.info kernel: [160168.366910] device wlan0 entered promiscuous mode
Tue Jun 23 16:36:46 2020 daemon.notice hostapd: wlan1: interface state COUNTRY_UPDATE->ACS
Tue Jun 23 16:36:46 2020 daemon.notice hostapd: wlan1: ACS-STARTED
Tue Jun 23 16:36:46 2020 daemon.err odhcpd[970]: Failed to send to ff02::1%lan@br-lan (Address not available)
Tue Jun 23 16:36:46 2020 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Tue Jun 23 16:36:46 2020 daemon.err hostapd: Using interface wlan0 with hwaddr 88:d7:f6:a8:1d:d8 and ssid "Surveillance_Van"
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: using nameserver 127.0.0.53#53
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: using local addresses only for domain lan
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: read /etc/hosts - 4 addresses
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: read /tmp/hosts/odhcpd - 0 addresses
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq-dhcp[10249]: read /etc/ethers - 0 addresses
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: read /etc/hosts - 4 addresses
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: read /tmp/hosts/odhcpd - 0 addresses
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq[10249]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Tue Jun 23 16:36:46 2020 daemon.info dnsmasq-dhcp[10249]: read /etc/ethers - 0 addresses
Tue Jun 23 16:36:46 2020 daemon.err odhcp6c[9856]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Tue Jun 23 16:36:47 2020 kern.info kernel: [160168.814038] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Tue Jun 23 16:36:47 2020 kern.info kernel: [160168.816455] br-lan: port 3(wlan0) entered blocking state
Tue Jun 23 16:36:47 2020 kern.info kernel: [160168.819758] br-lan: port 3(wlan0) entered forwarding state
Tue Jun 23 16:36:47 2020 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->ENABLED
Tue Jun 23 16:36:47 2020 daemon.notice hostapd: wlan0: AP-ENABLED
Tue Jun 23 16:36:47 2020 daemon.notice netifd: Network device 'wlan0' link is up

It was an issue at the ISP's end, which he resolved and now I am able to successfully get an IPv6 address.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.